前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >PTA 7-2 符号配对(20 分)

PTA 7-2 符号配对(20 分)

作者头像
Kindear
发布2017-12-29 18:01:02
5.7K0
发布2017-12-29 18:01:02
举报
7-2 符号配对(20 分)

请编写程序检查C语言源程序中下列符号是否配对:/**/()[]{}

输入格式:

输入为一个C语言源程序。当读到某一行中只有一个句点.和一个回车的时候,标志着输入结束。程序中需要检查配对的符号不超过100个。

输出格式:

首先,如果所有符号配对正确,则在第一行中输出YES,否则输出NO。然后在第二行中指出第一个不配对的符号:如果缺少左符号,则输出?-右符号;如果缺少右符号,则输出左符号-?

输入样例1:

void test()
{
    int i, A[10];
    for (i=0; i<10; i++) /*/
        A[i] = i;
}
.

输出样例1:

NO
/*-?

输入样例2:

void test()
{
    int i, A[10];
    for (i=0; i<10; i++) /**/
        A[i] = i;
}]
.

输出样例2:

NO
?-]

输入样例3:

void test()
{
    int i
    double A[10];
    for (i=0; i<10; i++) /**/
        A[i] = 0.1*i;
}
.

输出样例3:

YES
#include<cstdio>
#include<iostream>
#include<cmath>
#include<malloc.h>
#include<stdlib.h>
#include<string.h>
#include<cstring>
#define STACK_INIT_SIZE 10000
#define STACKINCREMENT 10
#define TRUE        1
#define FALSE       0
#define OK          1
#define ERROR       0
#define INFEASIBLE -1
#define OVERFLOW   -2
using namespace std;
typedef char SElemType,Status;
typedef struct
{
    SElemType *base;
    SElemType *top;
    int stacksize;
} Stack;
Status InitStack(Stack &S)
{
    S.base=(SElemType *)malloc(sizeof(SElemType)*STACK_INIT_SIZE);
    if(!S.base)
        exit(OVERFLOW);
    S.top=S.base;
    S.stacksize=STACK_INIT_SIZE;
    return OK;
}
Status Push(Stack &S,SElemType e)
{
    if(S.top-S.base>=S.stacksize)
    {
        S.base=(SElemType*)malloc(sizeof(SElemType)*(S.stacksize+STACKINCREMENT));
        if(!S.base)
            exit(OVERFLOW);
        S.top=S.base+S.stacksize;
        S.stacksize+=STACKINCREMENT;
    }
    *S.top++=e;
    return OK;

}
Status Pop(Stack &S)
{
    if(S.top==S.base)
        return ERROR;
    S.top--;
    return OK;
}
Status GetTop(Stack &S,SElemType &e)
{
    if(S.base==S.top)
        return ERROR;
    e=*(S.top-1);
    return OK;
}
const int maxn=1000+5;
char s[maxn];
bool Find(Stack &S,char ch)
{
    char tmp[maxn];
    memset(tmp,'\n',sizeof(tmp));
    int num=0;
    while(S.top!=S.base)
    {
        SElemType e2;
        GetTop(S,e2);
        if(e2==ch)
        {
            Pop(S);
            for(int i=num-1; i>=0; i--)
                Push(S,tmp[i]);
            return true;
        }
        else
        {
            tmp[num++]=e2;
        }
        Pop(S);
    }
    for(int i=num-1; i>=0; i--)
        Push(S,tmp[i]);
    return false;
}
void judge(char ch)
{
    if(ch=='(')
     printf("(-?\n");
     else if(ch=='[')
        printf("[-?\n");
     else if(ch=='{')
        printf("{-?\n");
     else if(ch=='<')
        printf("/*-?\n");
}
int main()
{
    Stack Sta;
    InitStack(Sta);
    int flag=1;
    while(gets(s))
    {
        if(s[0]=='.') break;
        int len=strlen(s);
        for(int i=0;i<strlen(s);i++)
        {
            if(s[i]=='('||s[i]=='['||s[i]=='{')
                Push(Sta,s[i]);
            else if(s[i]=='/'&&s[i+1]=='*'&&i+1<len)
            {
                ++i;
               Push(Sta,'<');
            }

            else if(s[i]==')')
            {

                if(Sta.top!=Sta.base)
                {
                    SElemType e;
                    GetTop(Sta,e);
                    if(e=='(')
                        Pop(Sta);
                    else if(flag)
                    {
                        printf("NO\n");
                        flag=0;
                        judge(e);
                    }
                }
                else if(flag)
                {
                    flag=0;
                    printf("NO\n");
                    printf("?-)\n");
                }


            }
            else if(s[i]==']')
            {

                if(Sta.top!=Sta.base)
                {
                    SElemType e;
                    GetTop(Sta,e);
                    if(e=='[')
                        Pop(Sta);
                    else if(flag)
                    {
                        printf("NO\n");
                        flag=0;
                        judge(e);
                    }
                }
                else if(flag)
                {
                    flag=0;
                    printf("NO\n");
                     printf("?-]\n");
                }


            }
            else if(s[i]=='}')
            {

                if(Sta.top!=Sta.base)
                {
                    SElemType e;
                    GetTop(Sta,e);
                    if(e=='{')
                        Pop(Sta);
                    else if(flag)
                    {
                        printf("NO\n");
                        flag=0;
                        judge(e);
                    }
                }
                else if(flag)
                {
                    flag=0;
                    printf("NO\n");
                     printf("?-}\n");
                }


            }
            else if(s[i]=='*'&&s[i+1]=='/'&&i+1<len)
            {
                ++i;
                if(Sta.top!=Sta.base)
                {
                    SElemType e;
                    GetTop(Sta,e);
                    if(e=='<')
                        Pop(Sta);
                    else if(flag)
                    {
                        printf("NO\n");
                        flag=0;
                        judge(e);
                    }
                }
                else if(flag)
                {
                    flag=0;
                    printf("NO\n");
                    printf("?-*/\n");
                }

            }
        }
    }
   if(flag)
   {
       if(Sta.base==Sta.top)
        printf("YES\n");
       else
       {
           SElemType e;
           GetTop(Sta,e);
           printf("NO\n");
           judge(e);
       }
   }
}
本文参与 腾讯云自媒体分享计划,分享自作者个人站点/博客。
原始发表:2017-11-07 ,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体分享计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
目录
  • 7-2 符号配对(20 分)
  • 输入格式:
  • 输出格式:
  • 输入样例1:
  • 输出样例1:
  • 输入样例2:
  • 输出样例2:
  • 输入样例3:
  • 输出样例3:
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档