maven 多个jar包版本依赖问题

  maven 中使用jar包的多个版本容易造成依赖问题,解决问题的方式可以将使用jar包的版本排除掉,比如dubbo使用netty 4.0.33版本可以将dubbo排除掉netty依赖,这样其他jar包就不会引用到netty4.0.33版本了。

  如下:

<dependency>
            <groupId>com.jd</groupId>
            <artifactId>jsf</artifactId>
            <version>1.6.0</version>
            <exclusions>
                <exclusion>
                    <groupId>io.netty</groupId>
                    <artifactId>netty-all</artifactId>
                </exclusion>
            </exclusions>
        </dependency>

1、通过idea workspace.xml可以看到jar包是被哪个jar包引入的。

2、通过去掉父依赖后,看idea左下工程依赖无相应jar后即解决了传递依赖问题。

本文参与腾讯云自媒体分享计划,欢迎正在阅读的你也加入,一起分享。

发表于

我来说两句

0 条评论
登录 后参与评论

扫码关注云+社区