6个常见的 PHP 安全性攻击

  了解常见的PHP应用程序安全威胁,可以确保你的PHP应用程序不受攻击。因此,本文将列出 6个常见的 PHP 安全性攻击,欢迎大家来阅读和学习。

  1、SQL注入

  SQL注入是一种恶意攻击,用户利用在表单字段输入SQL语句的方式来影响正常的SQL执行。还有一种是通过system()或exec()命令注入的,它具有相同的SQL注入机制,但只针对shell命令。

$username = $_POST['username']; $query = "select * from auth where username = '".$username."'"; echo $query; $db = new mysqli('localhost', 'demo', ‘demo', ‘demodemo'); $result = $db->query($query); if ($result && $result->num_rows) { echo "<br />Logged in successfully"; } else { echo "<br />Login failed"; }

  上面的代码,在第一行没有过滤或转义用户输入的值($_POST['username'])。因此查询可能会失败,甚至会损坏数据库,这要看$username是否包含变换你的SQL语句到别的东西上。

  防止SQL注入

  选项:

  使用mysql_real_escape_string()过滤数据

  手动检查每一数据是否为正确的数据类型

  使用预处理语句并绑定变量

  使用准备好的预处理语句

  分离数据和SQL逻辑

  预处理语句将自动过滤(如:转义)

  把它作为一个编码规范,可以帮助团队里的新人避免遇到以上问题

$query = 'select name, district from city where countrycode=?'; if ($stmt = $db->prepare($query) ) { $countrycode = 'hk'; $stmt->bind_param("s", $countrycode); $stmt->execute(); $stmt->bind_result($name, $district); while ( $stmt ($stmt->fetch() ){ echo $name.', '.$district; echo '<br />'; } $stmt->close(); }

  2、XSS攻击

  XSS(跨站点脚本攻击)是一种攻击,由用户输入一些数据到你的网站,其中包括客户端脚本(通常JavaScript)。如果你没有过滤就输出数据到另一个web页面,这个脚本将被执行。

  接收用户提交的文本内容

 <?php if (file_exists('comments')) { $comments = get_saved_contents_from_file('comments'); } else { $comments = ''; }

if (isset($_POST['comment'])) { $comments .= '<br />' . $_POST['comment']; save_contents_to_file('comments', $comments); } >

  输出内容给(另一个)用户

<form action='xss.php' method='POST'> Enter your comments here: <br /> <textarea name='comment'></textarea> <br /> <input type='submit' value='Post comment' /> </form><hr /><br />

<?php echo $comments; ?>

  将会发生什么事?

  烦人的弹窗

  刷新或重定向

  损坏网页或表单

  窃取cookie

  AJAX(XMLHttpRequest)

  防止XSS攻击

  为了防止XSS攻击,使用PHP的htmlentities()函数过滤再输出到浏览器。htmlentities()的基本用法很简单,但也有许多高级的控制,请参阅 XSS速查表

  3、会话固定

  会话安全,假设一个PHPSESSID很难猜测。然而,PHP可以接受一个会话ID通过一个Cookie或者URL。因此,欺骗一个受害者可以使用一个特定的(或其他的)会话ID 或者钓鱼攻击。

  4、会议捕获和劫持

  这是与会话固定有着同样的想法,然而,它涉及窃取会话ID。如果会话ID存储在Cookie中,攻击者可以通过XSS和JavaScript窃取。如果会话ID包含在URL上,也可以通过嗅探或者从代理服务器那获得。

  防止会话捕获和劫持

  更新ID

  如果使用会话,请确保用户使用SSL

  5、跨站点请求伪造(CSRF)

  CSRF攻击,是指一个页面发出的请求,看起来就像是网站的信任用户,但不是故意的。它有许多的变体,比如下面的例子:

<img src='http://example.com/single_click_to_buy.php?user_id=123&item=12345'>

  防止跨站点请求伪造

  一般来说,确保用户来自你的表单,并且匹配每一个你发送出去的表单。有两点一定要记住:

  对用户会话采用适当的安全措施,例如:给每一个会话更新id和用户使用SSL。

  生成另一个一次性的令牌并将其嵌入表单,保存在会话中(一个会话变量),在提交时检查它。

  6、代码注入

  代码注入是利用计算机漏洞通过处理无效数据造成的。问题出在,当你不小心执行任意代码,通常通过文件包含。写得很糟糕的代码可以允许一个远程文件包含并执行。如许多PHP函数,如require可以包含URL或文件名,例如:

 <form>Choose theme: <select name = theme> <option value = blue>Blue</option> <option value = green>Green</option> <option value = red>Red</option> </select> <input type = submit> </form> <?php if($theme) { require($theme.'.txt'); } ?>

  在上面的例子中,通过传递用户输入的一个文件名或文件名的一部分,来包含以"http://"开头的文件。

  防止代码注入

  过滤用户输入

  在php.ini中设置禁用allow_url_fopen和allow_url_include。这将禁用require/include/fopen的远程文件。

  其他的一般原则

  1. 不要依赖服务器配置来保护你的应用,特别是当你的web服务器/ PHP是由你的ISP管理,或者当你的网站可能迁移/部署到别处,未来再从别处迁移/部署在到其他地方。请在网站代码中嵌入带有安全意识的检查/逻辑 (HTML、JavaScript、PHP,等等)。

  2. 设计服务器端的安全脚本:

  —例如,使用单行执行 - 单点身份验证和数据清理

  —例如,在所有的安全敏感页面嵌入一个PHP函数/文件,用来处理所有登录/安全性逻辑检查

  3. 确保你的代码更新,并打上最新补丁。

原文发布于微信公众号 - php(phpdaily)

原文发表时间:2016-07-29

本文参与腾讯云自媒体分享计划,欢迎正在阅读的你也加入,一起分享。

发表于

我来说两句

0 条评论
登录 后参与评论

相关文章

来自专栏FreeBuf

XXE漏洞利用技巧:从XML到远程代码执行

如果你的应用是通过用户上传处理XML文件或POST请求(例如将SAML用于单点登录服务甚至是RSS)的,那么你很有可能会受到XXE的攻击。XXE是一种非常常见的...

812
来自专栏FreeBuf

Redis未授权访问配合SSH key文件利用分析

1.更新情况 ? 2.漏洞概述 Redis默认情况下,会绑定在0.0.0.0:6379,这样将会将Redis服务暴露到公网上,如果在没有开启认证的情况下,可以导...

2026
来自专栏FreeBuf

CSRF(跨站点请求伪造)在Flash中的利用

0x00 前言 CSRF(Cross-site request forgery)跨站请求伪造,也被称为“One Click Attack”或者Session R...

3155
来自专栏电光石火

SEVERE: Error configuring application listener of class org.springframework.web.context.ContextLoade

创建一个干净Spring MVC用Tomcat启动之后一直显示下面这个错误,网上找了很多方法也没有解决问题,后面最终找到终极解决方案 错误信息: ...

1697
来自专栏FreeBuf

Apache CVE-2017-7659漏洞重现及利用分析

近日,apache在其网站发布了最新的安全公告,其中涉及多个漏洞。针对CVE-2017-7659漏洞的介绍是这样的: A maliciously constru...

3006
来自专栏沈唁志

6个常见的 PHP 安全性攻击

1241
来自专栏小怪聊职场

安全|常见的Web攻击手段之CSRF攻击

3117
来自专栏Google Dart

AngularDart 4.0 高级-安全

本页面介绍了Angular内置的针对常见的Web应用程序漏洞和跨站脚本攻击等攻击的内置保护。 它不包括应用程序级别的安全性,如身份验证(此用户是谁?)和授权(此...

532
来自专栏北京马哥教育

自动化发布-GitLab WEB Hooks 配置

钩子(hooks) Git是在特定事件发生之前或之后执行特定脚本代码功能(从概念上类比,就与监听事件、触发器之类的东西类似)。 Git Hooks就是那些在Gi...

3185
来自专栏菩提树下的杨过

struts2使用Convention Plugin在weblogic上以war包部署时,找不到Action的解决办法

环境: struts 2.3.16.3 + Convention Plugin 2.3.16.3 实现零配置 现象:以文件夹方式部署在weblogic(10.3...

20010

扫描关注云+社区