前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >HDUOJ---3371Connect the Cities

HDUOJ---3371Connect the Cities

作者头像
Gxjun
发布2018-03-22 12:50:24
6480
发布2018-03-22 12:50:24
举报
文章被收录于专栏:mlml

Connect the Cities

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 7997    Accepted Submission(s): 2267

Problem Description

In 2100, since the sea level rise, most of the cities disappear. Though some survived cities are still connected with others, but most of them become disconnected. The government wants to build some roads to connect all of these cities again, but they don’t want to take too much money.  

Input

The first line contains the number of test cases. Each test case starts with three integers: n, m and k. n (3 <= n <=500) stands for the number of survived cities, m (0 <= m <= 25000) stands for the number of roads you can choose to connect the cities and k (0 <= k <= 100) stands for the number of still connected cities. To make it easy, the cities are signed from 1 to n. Then follow m lines, each contains three integers p, q and c (0 <= c <= 1000), means it takes c to connect p and q. Then follow k lines, each line starts with an integer t (2 <= t <= n) stands for the number of this connected cities. Then t integers follow stands for the id of these cities.

Output

For each case, output the least money you need to take, if it’s impossible, just output -1.

Sample Input

1 6 4 3 1 4 2 2 6 1 2 3 5 3 4 33 2 1 2 2 1 3 3 4 5 6

Sample Output

1

 代码:

代码语言:javascript
复制
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#define maxn 25005
typedef struct Side
{
    int vs;
    int ve;
    int cost;
}side;
side sta[maxn];
int father[505],rank[505];
void init(int n)
{
    for(int i=0 ;i<n ; i++)
    {
        father[i]=i;
           rank[i]=1;
    }
}

int setfind(int x)
{

    if(x!=father[x])
        father[x]=setfind(father[x]);
    return father[x];  //这里不能用x
}
void krusal(int a,int b)
{
    int x=setfind(a);
    int y=setfind(b);
    if(x==y) return ;
    if(x<y)
    {
     father[y]=x;
     rank[x]+=rank[y];
    }
    else
    {
    father[x]=y;
    rank[y]+=rank[x];
    }
}
int cmp(const void* a , const void* b)
{
    return (*(side*)a).cost-(*(side*)b).cost;
}
int main()
{
    int test,n,m,k,i,ans;
    scanf("%d",&test);
    while(test--)
    {
        ans=0;
        scanf("%d%d%d",&n,&m,&k);
        init(n);
        for(i=0; i<m ;i++)
        {
            scanf("%d%d%d",&sta[i].vs,&sta[i].ve,&sta[i].cost);
        }
        int a,b,c;
        for(i=0;i<k ;i++)
        {
            scanf("%d",&c);
            scanf("%d",&a);
            while(c-- >1)
            {
                scanf("%d",&b);
                krusal(a,b);
            }
        }
        qsort(sta,m,sizeof(sta[0]),cmp);
            for(i=0; i<m ;i++)
            {
                int tem1=setfind(sta[i].vs);
                int tem2=setfind(sta[i].ve);
                if(tem1 != tem2)
                {
                    krusal(tem1,tem2);
                    ans+=sta[i].cost;
                }
            }
        
        if(rank[0]==n)
        printf("%d\n",ans);
        else
            printf("-1\n");
    }
    return 0;
}
本文参与 腾讯云自媒体分享计划,分享自作者个人站点/博客。
原始发表:2014-02-26 ,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体分享计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
目录
  • Connect the Cities
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档