专栏首页about云hadoop,hbase,hive,zookeeper版本整合兼容性最全,最详细说明【适用于任何版本】

hadoop,hbase,hive,zookeeper版本整合兼容性最全,最详细说明【适用于任何版本】

问题导读 1.hadoop与hbase哪些版本兼容? 2.hadoop与hive哪些版本兼容? 3.hbase与hive哪些版本兼容? 4.hbase与zookeeper哪些版本兼容? 前言 之前写过hadoop、hbase、hive、zookeeper版本对应关系续(最新版) 【http://www.aboutyun.com/home.php?mod=space&uid=61&do=blog&id=62】 一篇文章,随着版本的更新,还是不能彻底解决大家对版本兼容的认识,一旦出新版本又不适用了,所以这里在写一篇文章,能否适用于任何版本。 当我们想整合hadoop,hbase,hive,zookeeper的时候,如果刚入门,可能认为这是比较简单的问题。但是当你自己真正想整合的时候,却会遇到很多的问题。 1.hadoop与hbase哪些版本兼容? 2.hadoop与hive哪些版本兼容? 3.hbase与hive哪些版本兼容? 4.hbase与zookeeper哪些版本兼容? 所以当我们真正想做整合的时候,我们需要解决上面四个问题,有些同学,忽略上面内容,直接部署,导致产生各种问题。 第一个问题,hadoop与hbase哪些版本兼容。 这里的每一个问题,当然我们需要引用官网的内容。

上面便是对照表,那么有了这个对照表,还是不行的。为什么因为你还是没有找到源头。如果随着版本更新,我们还是跟无头苍蝇一样,摸不着北。我们该如何能找到,我们该如何随着版本的更新,自己就能找到相关内容。 首先,进入下面网址 http://hbase.apache.org/book.html#arch.overview ,进入之后,我们同样需要会使用浏览器的查找功能,这样能让我们很快的定位。 浏览器的查找功能只要按照ctrl+F即可。这只是一个小技巧,还是比较实用的,然后我们输入

[Bash shell] 纯文本查看 复制代码

?

"S" = supported

这时候你就能找到hbase与hadoop的兼容信息了。如果你还是找不到,有下面两种方式: 1.about云论坛提问,会有比较多的热心人帮助 2.此版本内容会录制视频,欢迎捐助 hadoop生态系统零基础入门及大数据实战第一个问题算是解决,接着我们看第二个问题 2.hadoop与hive哪些版本兼容? hadoop与hive版本对应关系 hive版本 2.0.0 支持hadoop版本 Hadoop 2.x.y hive版本 1.2.1 支持hadoop版本 Hadoop 1.x.y, 2.x.y hive版本 1.0.1, 1.1.1 支持hadoop版本 Hadoop 1.x.y, 2.x.y hive版本 1.1.0 支持hadoop版本 Hadoop 1.x.y, 2.x.y hive版本 1.0.0支持hadoop版本 Hadoop 1.x.y, 2.x.y hive版本0.13.1支持hadoop版本 Hadoop 0.20.x, 0.23.x.y, 1.x.y, 2.x.y hive版本0.13.0支持hadoop版本 Hadoop 0.20.x, 0.23.x.y, 1.x.y, 2.x.y hive版本0.12.0支持hadoop版本 Hadoop 0.20.x, 0.23.x.y, 1.x.y, 2.x.y hive版本0.11.0支持hadoop版本 Hadoop 0.20.x, 0.23.x.y, 1.x.y, 2.x.y hive版本0.10.0支持hadoop版本 Hadoop 0.20.x, 0.23.x.y, 1.x.y, 2.x.y 上面是今年2016年更新内容. 那么我们该如何随着版本的更新,知道版本兼容? 收下我们打开下面网址: 网址:http://hive.apache.org/downloads.html 相信只要你会英文,就能看到下面内容

接着我们第三个问题 3.hbase与hive哪些版本兼容? hive0.90与hbase0.92是兼容的 早期的hive版本与hbase0.89/0.90兼容 当然上面的版本除非很早的时候用。 hive1.x与hbase0.98.x或则更低版本是兼容的。 hive2.x与hbase1.x及比hbase1.x更高版本兼容 如果想hbase1.x与hive1.x整合,需要编译hive1.x stream 代码本身 至于如何编译,如有时间在写文章。我们重点是上面如果版本更新,该如何获取最新信息。 我们可以进入下面网址 https://cwiki.apache.org/confluence/display/Hive/HBaseIntegration 下面中可以找到

上面我们已经解决,下面我们解决第四个问题 4.hbase与zookeeper哪些版本兼容? 对于zookeeper版本一般来讲越新越好,也就是我们安装hbase的时候,可以使用新版本。 那么这个兼容性就难不倒我们了,不过在安装过程中,为了稳定最好使用大家比较常用的版本 另外官网给出hbase1.0.0使用版本ZooKeeper 3.4.x

那么为了掌握最新信息,我们该如何随时获取zookeeper与hbase的信息,我们可以打开下面网址 http://hbase.apache.org/book.html#zookeeper 然后搜索 what version of zookeeper should i use 这时候你就找到相应的内容了。

本文分享自微信公众号 - about云(wwwaboutyuncom),作者:pig2

原文出处及转载信息见文内详细说明,如有侵权,请联系 yunjia_community@tencent.com 删除。

原始发表时间:2016-04-17

本文参与腾讯云自媒体分享计划,欢迎正在阅读的你也加入,一起分享。

我来说两句

0 条评论
登录 后参与评论

相关文章

  • CDH(Cloudera)与hadoop(apache)对比

    问题导读: 1.hadoop有几个版本? 2.CDH有几种安装方式? 3.CDH在安装认证方面做了什么改变? Cloudera的CDH和Apache的H...

    用户1410343
  • hadoop,hbase,hive,zookeeper整合可行性分析及版本确定【续篇】

    问题导读 1.如何确定什么版本是稳定版本? 2.本文是如何确定各个版本的? 3.hbase1.x与hive1.x什么情况下是兼容的? 前面一篇写过 had...

    用户1410343
  • hadoop入门:第十章hadoop工具

    问题导读 1.hadoop有哪些工具? 2.hadoop流的作用是什么? 3.hadoop集群负载如何模拟? 4.hadoop数据提取和分析工具是哪个? ...

    用户1410343
  • 问题与事务跟踪系统jira中的版本管理 转

    在jira中版本有三种状态,分别是:未发布/unreleased、发布/released、归档/archived。

    donghui
  • win10下安装GPU版本的TensorFlow(cuda + cudnn)

    搭了将近快两天的环境,终于好了,虽然在开始的时候,安了卸,卸了安的,但是!!!安装成功后,那种快乐是无法言语的~~~~~所以在此我必须的记录一下我的艰辛历程~~...

    andrew_a
  • Hadoop、Hbase、Hive版本兼容性

    当我们想整合hadoop,hbase,hive,zookeeper的时候,如果刚入门,可能认为这是比较简单的问题。但是当你自己真正想整合的时候,却会遇到很多的问...

    Albert陈凯
  • node的版本管理问题 转

    n是Node的一个模块,作者是TJ Holowaychuk(鼎鼎大名的Express框架作者) 安装很简单: $ sudo npm install -g n...

    双面人
  • windows下多版本python环境变量设置与pip不同版本方法(三步骤)

    1。对于两个版本首先要添加进去环境变量,这个很简单,网上有很多,一半找到文件所属目录即可,即文件属性(F:\anaconda2)

    学到老
  • 《Python核心编程》第五章

       在大多数32位机器上,标准整型的取值范围是-2^31~2^31-1,如果在64位机器上使用64位编译器编译的Python,则整型是64位的。而长整型能表...

    py3study
  • 解决mac升级10.11后,出现的 xcrun: error: invalid active developer path, missing xcrun 错误

    前天把小mac升级到了10.11,结果今天在终端里使用git的时候,弹出一行莫名其妙的错误:xcrun: error: invalid active devel...

    Allen Cheng

扫码关注云+社区

领取腾讯云代金券