【每日播报】如何升级Mininet的Open vSwitch版本

因为Mininet的方便且易用,以及实验条件及真实设备的不足,它已经被越来越多的SDN学习者使用。但在Mininet使用中,安装使用的内置Open vSwitch版本都比较低,使用者无法进行发布的新版本的使用及验证。因此,本文主要是将更新升级Mininet内置的Open vSwitch版本升级,通过重新下载安装Open vSwitch并进行配置,获取并使用Open vSwitch较高版本。

1 环境准备

主要使用ubuntu-13.10 64位操作系统,Mininet版本为2.1.0,内部已使用的Open vSwitch版本是1.10.2。 在Ubuntu13.10系统中安装Mininet-2.1.0版本简单提一下。

1.1 安装Mininet

1

sudo apt-get install mininet

1.2 禁止Open VSwitch Controller开机自启动

12

sudo service openvswitch-controller stopsudo update-rc.d openvswitch-controller disable

1.3 测试Mininet安装

1

sudo mn --test pingall

Mininet安装并验证成功后检验Mininet环境:

1、查看Mininet版本

12

# mn --version2.1.0

2、查看Open vSwitch版本

123

# ovs-vsctl --versionovs-vsctl (Open vSwitch) 1.10.2Compiled Sep 23 2013 14:53:13

2 操作步骤

2.1 下载Open vSwitch

我们升级Open vSwitch到目前最新的版本2.3.0(2014年8月14日发布),下载OpenvSwitch2.3.0(注:可下载自己需要安装的Open vSwitch版本)。

123456

cd /homemkdir openvswitchcd openvswitchwget http://openvswitch.org/releases/openvswitch-2.3.0.tar.gztar -xzf openvswitch-2.3.0.tar.gzcd openvswitch-2.3.0

注:为以防下文中生成的deb安装出现不必要的麻烦,建议新建目录openvswitch,在新建目录中下载Open vSwitch的包,以便后文生成的deb包在此目录下执行。

2.2 安装依赖

安装Open vSwitch需要如下依赖:

12

# apt-get install build-essential fakeroot# apt-get install debhelper autoconf automake libssl-dev pkg-config bzip2 openssl python-all procps python-qt4 python-zope.interface python-twisted-conch

执行下面命令检查依赖是否已全部安装,没有安装的继续安装:

1

dpkg-checkbuilddeps

2.3 编译Open vSwitch

构建Debian包:

1

fakeroot debian/rules binary

执行此命令后,将生成用于安装Open vSwitch交换机的deb包。

2.4 安装Open vSwitch

(1)安装Open vSwitch:

12

cd .. #即退出到新创建的openvswitch目录dpkg -i *.deb

(2)禁止Open VSwitch Controller开机自启动

12

# /etc/init.d/openvswitch-controller stop# update-rc.d openvswitch-controller disable

(3)重启Open vSwitch

1

/etc/init.d/openvswitch-switch restart

2.5 验证安装

检验OVS版本,版本已经由1.10.2升到到2.3.0:

1234

# ovs-vsctl --versionovs-vsctl (Open vSwitch) 2.3.0Compiled Nov 7 2014 09:38:44DB Schema 7.6.0

检验Mininet版本,Mininet版本还是2.1.0,如查看结果显示:

12

# mn --version2.1.0

验证Mininet是否在正常使用:

3 后语

以上就是升级Mininet里面的Open vSwitch版本的方法,但是目前的Mininet版本还不支持OpenFlow版本的选择,有兴趣的同学可以参考本网站的技术文章《OpenDaylight氦版本支持OpenFlow1.3协议验证》中的关于Mininet的OpenFlow1.3协议进一步配置。

原文发布于微信公众号 - SDNLAB(SDNLAB)

原文发表时间:2014-11-18

本文参与腾讯云自媒体分享计划,欢迎正在阅读的你也加入,一起分享。

发表于

我来说两句

0 条评论
登录 后参与评论

相关文章

来自专栏君赏技术博客

怎么让APP`iTunes Connect`名字和在设备上显示的名字是一致的

在iTunes Connect和设备上显示的名字是一致的,因为避免混淆。对于WatchKit的app,对于WatchKit应用程序,这意味着在iTunes Co...

29530
来自专栏iOS开发随笔

React Native 环境配置的坑

17730
来自专栏向治洪

Webpack+Babel+React开发环境搭建

前言 我们知道前端的框架纷繁复杂,各有各的优点。而我们选择使用React作为开发框架的时候,往往会选择Webpack+Babel+React来开始我们的项目。之...

25160
来自专栏假装我会写代码

highlight.js 在 Vue 中使用的一点儿经验

29020
来自专栏禅林阆苑

小程序开发总结01 - 模块化开发流程规范

H5 的开发涉及开发工具、前端框架、模块管理工具、任务管理工具、UI库、接口调用工具、各种浏览器运行环境等,尽管H5丰富的开发环境给了开发者更加灵活的配置方案,...

22370
来自专栏运维技术迷

Pycharm常用技巧

1.在Pycharm下为你的Python项目配置Python解释器 Project:当前项目名>Project Interpreter>add Local 2....

596120
来自专栏增长技术

Android-zipalign

13720
来自专栏HaHack

学习 React Native for Android:环境搭建

11620
来自专栏Jerry的SAP技术分享

在Windows笔记本上调试运行在iOS设备上的前端应用

我在每天工作中需要在不同的移动设备上测试我们开发的前端应用是否正常工作,比如iOS设备和Android设备。我用的工作笔记本电脑又是Lenovo的,安装的是Wi...

16810
来自专栏极乐技术社区

极乐问答No.2 | 微信小程序开发40问

导语 微信小程序开发者和开发需求者必读,内容涵盖小程序开发实战需要注意的40个技术点,供大家参考: ? 问答 Q Q1:为什么脚本内不能使用window等对象 ...

30580

扫码关注云+社区

领取腾讯云代金券