前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >UVa Automatic Editing

UVa Automatic Editing

作者头像
用户1624346
发布2018-04-11 17:26:43
5030
发布2018-04-11 17:26:43
举报
文章被收录于专栏:calmoundcalmound

uva的题真的很好,每个题都能长许多知识,A了后很开心,这道题我用了两天写,只一道题就学了四个函数,成长不少

Problem E: Automatic Editing

Source file:

autoedit.{c, cpp, java, pas}

Input file:

autoedit.in

Output file:

autoedit.out

Text-processing tools like awk and sed allow you to automatically perform a sequence of editing operations based on a script. For this problem we consider the specific case in which we want to perform a series of string replacements, within a single line of text, based on a fixed set of rules. Each rule specifies the string to find, and the string to replace it with, as shown below.

Rule Find Replace-by 1. ban bab 2. baba be 3. ana any 4. ba b hind the g

To perform the edits for a given line of text, start with the first rule. Replace the first occurrence of the find string within the text by thereplace-by string, then try to perform the same replacement again on the new text. Continue until the find string no longer occurs within the text, and then move on to the next rule. Continue until all the rules have been considered. Note that (1) when searching for a findstring, you always start searching at the beginning of the text, (2) once you have finished using a rule (because the find string no longer occurs) you never use that rule again, and (3) case is significant.

For example, suppose we start with the line

banana boat

and apply these rules. The sequence of transformations is shown below, where occurrences of a find string are underlined and replacements are boldfaced. Note that rule 1 was used twice, then rule 2 was used once, then rule 3 was used zero times, and then rule 4 was used once.

Before After banana boat babana boat babana boat bababa boat bababa boat beba boat beba boat behind the goat

The input contains one or more test cases, followed by a line containing only 0 (zero) that signals the end of the file. Each test case begins with a line containing the number of rules, which will be between 1 and 10. Each rule is specified by a pair of lines, where the first line is the find string and the second line is the replace-by string. Following all the rules is a line containing the text to edit. For each test case, output a line containing the final edited text.

Both find and replace-by strings will be at most 80 characters long. Find strings will contain at least one character, but replace-bystrings may be empty (indicated in the input file by an empty line). During the edit process the text may grow as large as 255 characters, but the final output text will be less than 80 characters long.

The first test case in the sample input below corresponds to the example shown above.

Example input:

4 ban bab baba be ana any ba b hind the g banana boat 1 t sh toe or top 0

Example output:

behind the goat shoe or shop

题意:替换,在再字符窜中找到能够替换的就替换。

 Note that (1) when searching for a findstring, you always start searching at the beginning of the text, (2) once you have finished using a rule (because the find string no longer occurs) you never use that rule again, and (3) case is significant.

For example, suppose we start with the line。找到一个就重新开始,一旦结束了一个语法就不能在使用了。题意。。。。

代码语言:javascript
复制
#include<stdio.h>
#include<string.h>
struct Node
{
    int len1,len2;
    char nam1[100],nam2[100];
}word[100];

int main()
{
    int n,i,j;
    char *pt,*px;
    char str[500],rem[500],ss[500];
    int cas,flag;
    while(scanf("%d",&n) && n)
    {
        getchar();
        for (i=0;i<n;i++)
        {
            gets(word[i].nam1);
            word[i].len1=strlen(word[i].nam1);
            gets(word[i].nam2);
            word[i].len2=strlen(word[i].nam2);
        }
        gets(str);
        strcpy(rem,str);
        for (i=0;i<n;i++)//单词个数
        {
            flag=0;
            pt=strstr(rem,word[i].nam1);
            if(pt!=NULL) flag=1;
            else continue;
            cas=0;
            for (px=rem;px!=pt;px++)//存储前半部分
            {
                ss[cas++]=*px;
            }
            ss[cas]='\0';
            pt+=word[i].len1;//抛弃该换掉的地方
            strcat(ss,word[i].nam2);//接入新的
            strcat(ss,pt);//接入剩余部分
            strcpy(rem,ss);
            if(flag) i-=1;
        }
        printf("%s\n",rem);
    }
    return 0;
}
本文参与 腾讯云自媒体分享计划,分享自作者个人站点/博客。
原始发表:2012-07-28 ,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体分享计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
目录
  • Problem E: Automatic Editing
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档