前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >UVA The ? 1 ? 2 ? ... ? n = k problem

UVA The ? 1 ? 2 ? ... ? n = k problem

作者头像
用户1624346
发布2018-04-17 15:56:54
5570
发布2018-04-17 15:56:54
举报
文章被收录于专栏:calmoundcalmound

The ? 1 ? 2 ? ... ? n = k problem

The problem

Given the following formula, one can set operators '+' or '-' instead of each '?', in order to obtain a given k ? 1 ? 2 ? ... ? n = k

For example: to obtain k = 12 , the expression to be used will be: - 1 + 2 + 3 + 4 + 5 + 6 - 7 = 12 with n = 7

The Input

The first line is the number of test cases, followed by a blank line.

Each test case of the input contains integer k (0<=|k|<=1000000000).

Each test case will be separated by a single line.

The Output

For each test case, your program should print the minimal possible n (1<=n) to obtain k with the above formula.

Print a blank line between the outputs for two consecutive test cases.

Sample Input

代码语言:javascript
复制
2

12

-3646397

Sample Output

代码语言:javascript
复制
7

2701

 题意:给定任意一个值k,使k=(-)1+(-)2+(-)3+(-)4+(-)5++++(-)n,求最小的n思路:S1=1+2+3+.....+n>=k,S2=1+2+3+...-x+...+n==k       所以S1-S2=2x,所以只要有一个数导致S1和S2差为偶数就符合条件       输出有空格,再次错了。      数学真强大,这里完全体现

代码语言:javascript
复制
#include<stdio.h>
#include<stdlib.h>

int main()
{
    long long k,t;
    int n;
    int T,i;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%lld",&k);
        k=abs(k);
        for(i=1;;i++)
        {
            t=i*(i+1)/2;
            if(t>=k) break;
        }
        n=i;
        while(1)
        {
           int xx=n*(n+1)/2-k;
           if(xx%2==0) break;
           n++;
        }
        printf("%d\n",n);
        if(T) printf("\n");
    }
    return 0;
}
本文参与 腾讯云自媒体分享计划,分享自作者个人站点/博客。
原始发表:2012-08-28 ,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体分享计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
目录
  • The problem
  • The Input
  • The Output
  • Sample Input
  • Sample Output
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档