前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >POJ-1125 Stockbroker Grapevine

POJ-1125 Stockbroker Grapevine

作者头像
ShenduCC
发布2018-04-25 17:21:20
5700
发布2018-04-25 17:21:20
举报
文章被收录于专栏:算法修养算法修养

Stockbroker Grapevine Time Limit: 1000MS Memory Limit: 10000K Total Submissions: 32193 Accepted: 17692 Description

Stockbrokers are known to overreact to rumours. You have been contracted to develop a method of spreading disinformation amongst the stockbrokers to give your employer the tactical edge in the stock market. For maximum effect, you have to spread the rumours in the fastest possible way.

Unfortunately for you, stockbrokers only trust information coming from their “Trusted sources” This means you have to take into account the structure of their contacts when starting a rumour. It takes a certain amount of time for a specific stockbroker to pass the rumour on to each of his colleagues. Your task will be to write a program that tells you which stockbroker to choose as your starting point for the rumour, as well as the time it will take for the rumour to spread throughout the stockbroker community. This duration is measured as the time needed for the last person to receive the information. Input

Your program will input data for different sets of stockbrokers. Each set starts with a line with the number of stockbrokers. Following this is a line for each stockbroker which contains the number of people who they have contact with, who these people are, and the time taken for them to pass the message to each person. The format of each stockbroker line is as follows: The line starts with the number of contacts (n), followed by n pairs of integers, one pair for each contact. Each pair lists first a number referring to the contact (e.g. a ‘1’ means person number one in the set), followed by the time in minutes taken to pass a message to that person. There are no special punctuation symbols or spacing rules.

Each person is numbered 1 through to the number of stockbrokers. The time taken to pass the message on will be between 1 and 10 minutes (inclusive), and the number of contacts will range between 0 and one less than the number of stockbrokers. The number of stockbrokers will range from 1 to 100. The input is terminated by a set of stockbrokers containing 0 (zero) people.

Output

For each set of data, your program must output a single line containing the person who results in the fastest message transmission, and how long before the last person will receive any given message after you give it to this person, measured in integer minutes. It is possible that your program will receive a network of connections that excludes some persons, i.e. some people may be unreachable. If your program detects such a broken network, simply output the message “disjoint”. Note that the time taken to pass the message from person A to person B is not necessarily the same as the time taken to pass it from B to A, if such transmission is possible at all. Sample Input

3 2 2 4 3 5 2 1 2 3 6 2 1 2 2 2 5 3 4 4 2 8 5 3 1 5 8 4 1 6 4 10 2 7 5 2 0 2 2 5 1 5 0 Sample Output

3 2 3 10

题意:给你一群人之间的关系,让传播一个消息,每个人传给每个人都有相应的价值,要求价值最小而且,每个人都能知道 思路:这是个最短路问题,先用Floyed或者Dijskra,求出任意两个点的最短路,然后就是枚举了。找出一个点,这个点到其他点的最短路的最大值,在所有点中是最小的,如果这个最大值是MAX,那这个点就不能联通图了。1

代码语言:javascript
复制
#include <iostream>
#include <algorithm>
#include <math.h>
#include <string.h>
#include <stdlib.h>
#include <stdio.h>

using namespace std;
#define MAX 100
int a[105][105];
int n;
int num;
int x,w;
int ans;
int start;
void init()
{
    for(int i=1;i<=n;i++)
    {
        for(int j=1;j<=n;j++)
            a[i][j]=MAX;
        a[i][i]=0;
    }
}
void Floyed()
{
    for(int k=1;k<=n;k++)
    {
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=n;j++)
            {
                if(i!=j&&a[i][j]>a[i][k]+a[k][j])
                    a[i][j]=a[i][k]+a[k][j];
            }
        }
    }
}
void print()
{
    for(int i=1;i<=n;i++)
    {
        for(int j=1;j<=n;j++)
            printf("%d       ",a[i][j]);
        printf("\n");
    }
}
int main()
{
    int res;
    while(scanf("%d",&n)!=EOF)
    {
        if(n==0)
            break;
        res=MAX;
        ans=0;
        init();
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&num);
            for(int j=1;j<=num;j++)
            {
                scanf("%d%d",&x,&w);
                a[i][x]=w;
            }
        }
        //print();
        Floyed();
        //print();
        for(int i=1;i<=n;i++)
        {
            int  maxin=0;
            for(int j=1;j<=n;j++)
            {
                if(i!=j)
                {
                    if(maxin<a[i][j])
                        maxin=a[i][j];
                }
            }
            if(res>maxin)
            {
                res=maxin;
                start=i;
            }
        }
        if(res==MAX)
            printf("disjoint\n");
        else
            printf("%d %d\n",start,res);
    }
    return 0;
}
本文参与 腾讯云自媒体分享计划,分享自作者个人站点/博客。
原始发表:2015-12-15 ,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体分享计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档