前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >POJ-1952 BUY LOW, BUY LOWER(线性DP)

POJ-1952 BUY LOW, BUY LOWER(线性DP)

作者头像
ShenduCC
发布2018-04-25 17:36:00
5910
发布2018-04-25 17:36:00
举报
文章被收录于专栏:算法修养

BUY LOW, BUY LOWER Time Limit: 1000MS Memory Limit: 30000K Total Submissions: 9244 Accepted: 3226 Description

The advice to “buy low” is half the formula to success in the bovine stock market.To be considered a great investor you must also follow this problems’ advice: “Buy low; buy lower”

Each time you buy a stock, you must purchase it at a lower price than the previous time you bought it. The more times you buy at a lower price than before, the better! Your goal is to see how many times you can continue purchasing at ever lower prices.

You will be given the daily selling prices of a stock (positive 16-bit integers) over a period of time. You can choose to buy stock on any of the days. Each time you choose to buy, the price must be strictly lower than the previous time you bought stock. Write a program which identifies which days you should buy stock in order to maximize the number of times you buy.

Here is a list of stock prices: Day 1 2 3 4 5 6 7 8 9 10 11 12

Price 68 69 54 64 68 64 70 67 78 62 98 87

The best investor (by this problem, anyway) can buy at most four times if each purchase is lower then the previous purchase. One four day sequence (there might be others) of acceptable buys is: Day 2 5 6 10

Price 69 68 64 62 Input

  • Line 1: N (1 <= N <= 5000), the number of days for which stock prices are given
  • Lines 2..etc: A series of N space-separated integers, ten per line except the final line which might have fewer integers. Output

Two integers on a single line: * The length of the longest sequence of decreasing prices * The number of sequences that have this length (guaranteed to fit in 31 bits)

In counting the number of solutions, two potential solutions are considered the same (and would only count as one solution) if they repeat the same string of decreasing prices, that is, if they “look the same” when the successive prices are compared. Thus, two different sequence of “buy” days could produce the same string of decreasing prices and be counted as only a single solution. Sample Input

12 68 69 54 64 68 64 70 67 78 62 98 87 Sample Output

4 2

关键是判断最长下降子序列有多少个,要用两个状态数组,一个是求最长下降子序列,一个求个数,注意判重

代码语言:javascript
复制
#include <iostream>
#include <string.h>
#include <stdlib.h>
#include <algorithm>
#include <math.h>

using namespace std;
#define MAX 5000
int dp[MAX+5];
int cnt[MAX+5];
int n;
int a[MAX+5];
int main()
{
    while(scanf("%d",&n)!=EOF)
    {
        for(int i=0;i<n;i++)
            scanf("%d",&a[i]);
        a[n]=-1;
        memset(dp,0,sizeof(dp));
        for(int i=0;i<=n;i++)
        {
            int num=0;
            for(int j=i-1;j>=0;j--)
            {
                if(a[j]>a[i])
                {
                    if(num<dp[j])
                        num=dp[j];
                }
            }
            dp[i]=num+1;
        }
        memset(cnt,0,sizeof(cnt));
        bool tag;
        for(int i=0;i<=n;i++)
        {
            if(dp[i]==1)
            {
                cnt[i]=1;continue;
            }
            for(int j=i-1;j>=0;j--)
            {

                if(a[j]>a[i]&&dp[j]==dp[i]-1)
                {
                    tag=true;
                    for(int k=j+1;k<i;k++)
                        if(a[k]==a[j])
                        {
                            tag=false;
                            break;
                        }
                    if(tag)
                        cnt[i]+=cnt[j];

                }

            }
        }
        printf("%d %d\n",dp[n]-1,cnt[n]);

    }
    return 0;
}
本文参与 腾讯云自媒体同步曝光计划,分享自作者个人站点/博客。
原始发表:2016-01-04 ,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体同步曝光计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档