前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >POJ-2029 Get Many Persimmon Trees(动态规划)

POJ-2029 Get Many Persimmon Trees(动态规划)

作者头像
ShenduCC
发布2018-04-26 10:34:08
4860
发布2018-04-26 10:34:08
举报
文章被收录于专栏:算法修养算法修养

Get Many Persimmon Trees Time Limit: 1000MS Memory Limit: 30000K Total Submissions: 3987 Accepted: 2599 Description

Seiji Hayashi had been a professor of the Nisshinkan Samurai School in the domain of Aizu for a long time in the 18th century. In order to reward him for his meritorious career in education, Katanobu Matsudaira, the lord of the domain of Aizu, had decided to grant him a rectangular estate within a large field in the Aizu Basin. Although the size (width and height) of the estate was strictly specified by the lord, he was allowed to choose any location for the estate in the field. Inside the field which had also a rectangular shape, many Japanese persimmon trees, whose fruit was one of the famous products of the Aizu region known as ‘Mishirazu Persimmon’, were planted. Since persimmon was Hayashi’s favorite fruit, he wanted to have as many persimmon trees as possible in the estate given by the lord. For example, in Figure 1, the entire field is a rectangular grid whose width and height are 10 and 8 respectively. Each asterisk (*) represents a place of a persimmon tree. If the specified width and height of the estate are 4 and 3 respectively, the area surrounded by the solid line contains the most persimmon trees. Similarly, if the estate’s width is 6 and its height is 4, the area surrounded by the dashed line has the most, and if the estate’s width and height are 3 and 4 respectively, the area surrounded by the dotted line contains the most persimmon trees. Note that the width and height cannot be swapped; the sizes 4 by 3 and 3 by 4 are different, as shown in Figure 1.

Figure 1: Examples of Rectangular Estates

Your task is to find the estate of a given size (width and height) that contains the largest number of persimmon trees. Input

The input consists of multiple data sets. Each data set is given in the following format.

N W H x1 y1 x2 y2 … xN yN S T

N is the number of persimmon trees, which is a positive integer less than 500. W and H are the width and the height of the entire field respectively. You can assume that both W and H are positive integers whose values are less than 100. For each i (1 <= i <= N), xi and yi are coordinates of the i-th persimmon tree in the grid. Note that the origin of each coordinate is 1. You can assume that 1 <= xi <= W and 1 <= yi <= H, and no two trees have the same positions. But you should not assume that the persimmon trees are sorted in some order according to their positions. Lastly, S and T are positive integers of the width and height respectively of the estate given by the lord. You can also assume that 1 <= S <= W and 1 <= T <= H.

The end of the input is indicated by a line that solely contains a zero. Output

For each data set, you are requested to print one line containing the maximum possible number of persimmon trees that can be included in an estate of the given size. Sample Input

16 10 8 2 2 2 5 2 7 3 3 3 8 4 2 4 5 4 8 6 4 6 7 7 5 7 8 8 1 8 4 9 6 10 3 4 3 8 6 4 1 2 2 1 2 4 3 4 4 2 5 3 6 1 6 2 3 2 0 Sample Output

4 3

可以将二维转换成一维,然后在dp求解

代码语言:javascript
复制
#include <iostream>
#include <string.h>
#include <algorithm>
#include <math.h>
#include <stdlib.h>

using namespace std;
int dp[105];
int d[105];
int c[105][105];
int n;
int x,y;
int a,b;
int w,h;
int main()
{
    int ans;
    int sum;
    while(scanf("%d",&n)!=EOF)
    {
        if(n==0)
            break;
        ans=0;
        scanf("%d%d",&a,&b);
        memset(c,0,sizeof(c));
        for(int i=1;i<=n;i++)
        {
            scanf("%d%d",&x,&y);
            c[y][x]=1;
        }
        scanf("%d%d",&w,&h);
        for(int i=1;i<=b-h+1;i++)
        {
            memset(d,0,sizeof(d));
            memset(dp,0,sizeof(dp));
            for(int p=0;p<h;p++)
                for(int j=1;j<=a;j++)
                    d[j]+=c[i+p][j];
            for(int k=1;k<=w;k++)
                dp[w]+=d[k];
            for(int j=w+1;j<=a;j++)
            {
                sum=0;
                for(int k=j;k>=j-w+1;k--)
                    sum+=d[k];
                dp[j]=max(dp[j-1],sum);

            }

            if(ans<dp[a])
                ans=dp[a];
        }
        printf("%d\n",ans);
    }
}
本文参与 腾讯云自媒体分享计划,分享自作者个人站点/博客。
原始发表:2016-01-07 ,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体分享计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档