前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >HOJ 2124 &POJ 2663Tri Tiling(动态规划)

HOJ 2124 &POJ 2663Tri Tiling(动态规划)

作者头像
ShenduCC
发布2018-04-26 11:23:55
5440
发布2018-04-26 11:23:55
举报
文章被收录于专栏:算法修养

Tri Tiling Time Limit: 1000MS Memory Limit: 65536K Total Submissions: 9016 Accepted: 4684 Description

In how many ways can you tile a 3xn rectangle with 2x1 dominoes? Here is a sample tiling of a 3x12 rectangle.

Input

Input consists of several test cases followed by a line containing -1. Each test case is a line containing an integer 0 <= n <= 30. Output

For each test case, output one integer number giving the number of possible tilings. Sample Input

2 8 12 -1 Sample Output

3 153 2131 Source

之前也写过这种堆方块,就是找递推的方程,还是比较简单的题目。但是这道题目却是一个升级,因为他的递推方程需要变形,所以以后遇到这类题目就又多了一点见识。 dp[n]=3*dp[n-2]+2*dp[n-4]+2*dp[n-6]+……2*dp[0]; 如果只拿这个方程去解肯定麻烦或者还可能超时 变形 dp[n-2]=3*dp[n-4]+2*(dp[n-6]+dp[n-8]+…..dp[0]); dp[n-2]-dp[n-4]=2*(dp[n-4]+dp[n-6]+dp[n-8]+….dp[0]); dp[n]=4*dp[n-2]-dp[n-4]; 就搞定了,

代码语言:javascript
复制
#include <iostream>
#include <string.h>
#include <stdlib.h>
#include <math.h>
#include <algorithm>

using namespace std;
int dp[35];
int n;
int main()
{
    dp[0]=1;
    dp[1]=0;
    dp[2]=3;
    for(int i=3;i<=30;i++)
    {
         if(i&1)
            dp[i]=0;
        else
            dp[i]=dp[i-2]*4-dp[i-4];
    }
    while(scanf("%d",&n)!=EOF)
    {
        if(n==-1)
            break;
        printf("%d\n",dp[n]);
    }
    return 0;
}
本文参与 腾讯云自媒体同步曝光计划,分享自作者个人站点/博客。
原始发表:2016-03-04 ,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体同步曝光计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档