前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >HDU 3903 Trigonometric Function(数学定理)

HDU 3903 Trigonometric Function(数学定理)

作者头像
ShenduCC
发布2018-04-26 11:30:55
4660
发布2018-04-26 11:30:55
举报
文章被收录于专栏:算法修养算法修养算法修养

Trigonometric Function

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 125536/65536 K (Java/Others) Total Submission(s): 693 Accepted Submission(s): 277

Problem Description Give you a triangle ABC. Get more information in the picture below.

Now, give you 6 integers a, b, c, n, m and k. a, b and c are triangle ABC`s three edges. Can you judge whether the result of the following fraction is rational number?

Input There are several test cases in the input data. Each case is just one line with 6 integers – a, b, c, n, m, k (0< a, b, c, n, m, k < 10^4) separated by spaces. The input data ensures that sin(kC) will not be equal with 0.

Output Each case output “YES”, if the result of the fraction is rational number, otherwise “NO”.

Sample Input 2 1 1 1 1 1 1 3 4 5 6 7 7

Sample Output NO YES

若n为有理数,那么cos(n)一定是有理数 cos( k*n )一定是有理数 sin(n)确不一定。 所以只要判断分母是不是有理数就好了,sin(k*n)

#include <iostream>
#include <string.h>
#include <stdlib.h>
#include <algorithm>
#include <math.h>
#include <stdio.h>

using namespace std;
long long int a,b,c,n,m,k;
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%lld%lld%lld%lld%lld%lld",&a,&b,&c,&n,&m,&k);
        long long int num=4*a*a*b*b-(a*a+b*b-c*c)*(a*a+b*b-c*c);
        long long int t=sqrt(1.0*num);
        if(t*t==num)
            printf("YES\n");
        else
            printf("NO\n");
    }
    return 0;
}
本文参与 腾讯云自媒体分享计划,分享自作者个人站点/博客。
原始发表:2016-03-09 ,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体分享计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档