前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >FZU 2107 Hua Rong Dao(dfs)

FZU 2107 Hua Rong Dao(dfs)

作者头像
ShenduCC
发布2018-04-26 12:00:41
5800
发布2018-04-26 12:00:41
举报
文章被收录于专栏:算法修养

Problem 2107 Hua Rong Dao Accept: 318 Submit: 703 Time Limit: 1000 mSec Memory Limit : 32768 KB

Problem Description

Cao Cao was hunted down by thousands of enemy soldiers when he escaped from Hua Rong Dao. Assuming Hua Rong Dao is a narrow aisle (one N*4 rectangle), while Cao Cao can be regarded as one 2*2 grid. Cross general can be regarded as one 1*2 grid.Vertical general can be regarded as one 2*1 grid. Soldiers can be regarded as one 1*1 grid. Now Hua Rong Dao is full of people, no grid is empty.

There is only one Cao Cao. The number of Cross general, vertical general, and soldier is not fixed. How many ways can all the people stand?

Input

There is a single integer T (T≤4) in the first line of the test data indicating that there are T test cases.

Then for each case, only one integer N (1≤N≤4) in a single line indicates the length of Hua Rong Dao.

Output

For each test case, print the number of ways all the people can stand in a single line. Sample Input

2 1 2 Sample Output

0 18

暴力搜索

代码语言:javascript
复制
#include <iostream>
#include <string.h>
#include <stdlib.h>
#include <algorithm>
#include <math.h>
#include <stdio.h>

using namespace std;
int vis[10][10];
int n;
int ans;
bool flag;
int judge(int x,int y)
{
    if(x<1||x>n||y<1||y>4||vis[x][y])
        return 0;
    return 1;
}
void dfs(int count)
{
    if(count==n*4&&flag)
    {
        ans++;
        return;
    }
    if(count>=n*4)
        return;
    for(int i=1;i<=n;i++)
    {
        for(int j=1;j<=4;j++)
        {
            if(judge(i,j)&&judge(i+1,j+1)&&judge(i,j+1)&&judge(i+1,j)&&!flag)
            {
                flag=1;
                vis[i][j]=1;vis[i+1][j+1]=1;vis[i][j+1]=1;vis[i+1][j]=1;
                dfs(count+4);
                flag=0;
                vis[i][j]=0;vis[i+1][j+1]=0;vis[i][j+1]=0;vis[i+1][j]=0;
            }
            if(judge(i,j)&&judge(i,j+1))
            {
                vis[i][j]=1;vis[i][j+1]=1;
                dfs(count+2);
                vis[i][j]=0;vis[i][j+1]=0;
            }
            if(judge(i,j)&&judge(i+1,j))
            {
                vis[i][j]=1;vis[i+1][j]=1;
                dfs(count+2);
                vis[i][j]=0;vis[i+1][j]=0;
            }
            if(judge(i,j))
            {
                vis[i][j]=1;
                dfs(count+1);
                vis[i][j]=0;
                return;

            }


        }
    }
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        memset(vis,0,sizeof(vis));
        ans=0;
        flag=0;
        dfs(0);
        printf("%d\n",ans);
    }
    return 0;

}
本文参与 腾讯云自媒体同步曝光计划,分享自作者个人站点/博客。
原始发表:2016-03-12 ,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体同步曝光计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档