前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >ZOJ 3710 Friends

ZOJ 3710 Friends

作者头像
ShenduCC
发布2018-04-26 16:07:11
3810
发布2018-04-26 16:07:11
举报
文章被收录于专栏:算法修养算法修养

Alice lives in the country where people like to make friends. The friendship is bidirectional and if any two person have no less than k friends in common, they will become friends in several days. Currently, there are totally n people in the country, and m friendship among them. Assume that any new friendship is made only when they have sufficient friends in common mentioned above, you are to tell how many new friendship are made after a sufficiently long time.

Input

There are multiple test cases.

The first lien of the input contains an integer T (about 100) indicating the number of test cases. Then T cases follow. For each case, the first line contains three integers n, m, k (1 ≤ n ≤ 100, 0 ≤ m ≤ n×(n-1)/2, 0 ≤ k ≤ n, there will be no duplicated friendship) followed by m lines showing the current friendship. The ith friendship contains two integers ui, vi (0 ≤ ui, vi < n, ui ≠ vi) indicating there is friendship between person ui and vi.

Note: The edges in test data are generated randomly.

Output

For each case, print one line containing the answer.

Sample Input
代码语言:javascript
复制
3
4 4 2
0 1
0 2
1 3
2 3
5 5 2
0 1
1 2
2 3
3 4
4 0
5 6 2
0 1
1 2
2 3
3 4
4 0
2 0
Sample Output
代码语言:javascript
复制
2
0
4
暴力来就好了<pre name="code" class="html">#include <iostream>
#include <string.h>
#include <stdlib.h>
#include <stdio.h>
#include <algorithm>
#include <math.h>

using namespace std;
int v[105][105];
int n,m,k,t;
int ans;
int main()
{
    int x,y;
     while(scanf("%d",&t)!=EOF)
     {
         while(t--)
         {
             scanf("%d%d%d",&n,&m,&k);
             memset(v,0,sizeof(v));
             for(int i=1;i<=m;i++)
             {
                 scanf("%d%d",&x,&y);
                 v[x][y]=v[y][x]=1;
             }
             ans=0;
             while(1)
             {
                 bool flag=false;
                 for(int i=0;i<n;i++)
                 {
                     for(int j=i+1;j<n;j++)
                     {
                         if(v[i][j]) continue;
                         int num=0;
                         for(int k=0;k<n;k++)
                         {
                             if(v[i][k]&&v[j][k])
                                num++;
                         }
                         if(num>=k)
                         {
                             flag=true;
                             v[i][j]=v[j][i]=1;
                             ans++;
                         }
                     }
                 }
                 if(!flag)
                    break;
             }
             printf("%d\n",ans);
         }
     }
     return 0;
}
本文参与 腾讯云自媒体分享计划,分享自作者个人站点/博客。
原始发表:2016-04-14 ,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体分享计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
目录
  • Input
  • Output
  • Sample Input
  • Sample Output
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档