前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >ZOJ 3607 Lazier Salesgirl (枚举)

ZOJ 3607 Lazier Salesgirl (枚举)

作者头像
ShenduCC
发布2018-04-26 16:21:16
4660
发布2018-04-26 16:21:16
举报
文章被收录于专栏:算法修养算法修养

Lazier Salesgirl Time Limit: 2 Seconds Memory Limit: 65536 KB Kochiya Sanae is a lazy girl who makes and sells bread. She is an expert at bread making and selling. She can sell the i-th customer a piece of bread for price pi. But she is so lazy that she will fall asleep if no customer comes to buy bread for more than w minutes. When she is sleeping, the customer coming to buy bread will leave immediately. It’s known that she starts to sell bread now and the i-th customer come after ti minutes. What is the minimum possible value of w that maximizes the average value of the bread sold?

Input

There are multiple test cases. The first line of input is an integer T ≈ 200 indicating the number of test cases.

The first line of each test case contains an integer 1 ≤ n ≤ 1000 indicating the number of customers. The second line contains n integers 1 ≤ pi ≤ 10000. The third line contains n integers 1 ≤ ti ≤ 100000. The customers are given in the non-decreasing order of ti.

Output

For each test cases, output w and the corresponding average value of sold bread, with six decimal digits.

Sample Input

2 4 1 2 3 4 1 3 6 10 4 4 3 2 1 1 3 6 10 Sample Output

4.000000 2.500000 1.000000 4.000000

枚举

代码语言:javascript
复制
#include <iostream>
#include <string.h>
#include <stdio.h>
#include <math.h>
#include <stdlib.h>
#include <algorithm>

using namespace std;
int n;
int p[1005];
int t[1005];
int w;
int main()
{
    int t1;
    scanf("%d",&t1);
    while(t1--)
    {
        scanf("%d",&n);
        for(int i=1;i<=n;i++)
            scanf("%d",&p[i]);
        int num1=0;
        int num2=100000;
        t[0]=0;
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&t[i]);
            num1=max(num1,t[i]-t[i-1]);
            num2=min(num2,t[i]-t[i-1]);
        }
        int pos=1;
        double res=0;
        double ans;
        for(w=num2;w<=num1;w++)
        {
            int sum=0;int num=0;
            int time=w;
            for(int i=1;i<=n;i++)
            {
                if(t[i]<=time)
                {
                    sum+=p[i];
                    num++;
                    time=t[i]+w;
                }
                else
                {
                    break;
                }
            }
            double av=1.0*sum/num;
            if(res<av)
            {
                res=av;
                ans=w;
            }

        }
        printf("%.6f %.6f\n",ans,res);

    }
    return 0;
}
本文参与 腾讯云自媒体分享计划,分享自作者个人站点/博客。
原始发表:2016-04-19 ,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体分享计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档