前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >ZOJ 3609 Modular Inverse

ZOJ 3609 Modular Inverse

作者头像
ShenduCC
发布2018-04-26 16:21:40
5220
发布2018-04-26 16:21:40
举报
文章被收录于专栏:算法修养算法修养

Modular Inverse Time Limit: 2 Seconds Memory Limit: 65536 KB The modular modular multiplicative inverse of an integer a modulo m is an integer x such that a-1≡x (mod m). This is equivalent to ax≡1 (mod m).

Input

There are multiple test cases. The first line of input is an integer T ≈ 2000 indicating the number of test cases.

Each test case contains two integers 0 < a ≤ 1000 and 0 < m ≤ 1000.

Output

For each test case, output the smallest positive x. If such x doesn’t exist, output “Not Exist”.

Sample Input

3 3 11 4 12 5 13 Sample Output

4 Not Exist 8

代码语言:javascript
复制
#include <iostream>
#include <string.h>
#include <stdio.h>
#include <math.h>
#include <stdlib.h>
#include <algorithm>

using namespace std;
int a,m;
int tag[1005];
int ans;
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&a,&m);
        int x=1;
        bool flag=true;
        memset(tag,0,sizeof(tag));
        while(1)
        {
            if(((a*x)%m)==(1%m))
            {ans=x;break;}
            else
            {
                x++;
                int num=(a*x)%m;
                if(tag[num])
                {
                    flag=false;
                    break;
                }
                tag[num]=1;

            }
        }
        if(!flag)
            printf("Not Exist\n");
        else
            printf("%d\n",ans);
    }
    return 0;
}
本文参与 腾讯云自媒体分享计划,分享自作者个人站点/博客。
原始发表:2016-04-19 ,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体分享计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档