前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >PAT 1026 Table Tennis (30)

PAT 1026 Table Tennis (30)

作者头像
ShenduCC
发布2018-04-26 16:22:04
7810
发布2018-04-26 16:22:04
举报
文章被收录于专栏:算法修养算法修养

A table tennis club has N tables available to the public. The tables are numbered from 1 to N. For any pair of players, if there are some tables open when they arrive, they will be assigned to the available table with the smallest number. If all the tables are occupied, they will have to wait in a queue. It is assumed that every pair of players can play for at most 2 hours.

Your job is to count for everyone in queue their waiting time, and for each table the number of players it has served for the day.

One thing that makes this procedure a bit complicated is that the club reserves some tables for their VIP members. When a VIP table is open, the first VIP pair in the queue will have the priviledge to take it. However, if there is no VIP in the queue, the next pair of players can take it. On the other hand, if when it is the turn of a VIP pair, yet no VIP table is available, they can be assigned as any ordinary players.

Input Specification:

Each input file contains one test case. For each case, the first line contains an integer N (<=10000) - the total number of pairs of players. Then N lines follow, each contains 2 times and a VIP tag: HH:MM:SS - the arriving time, P - the playing time in minutes of a pair of players, and tag - which is 1 if they hold a VIP card, or 0 if not. It is guaranteed that the arriving time is between 08:00:00 and 21:00:00 while the club is open. It is assumed that no two customers arrives at the same time. Following the players’ info, there are 2 positive integers: K (<=100) - the number of tables, and M (< K) - the number of VIP tables. The last line contains M table numbers.

Output Specification:

For each test case, first print the arriving time, serving time and the waiting time for each pair of players in the format shown by the sample. Then print in a line the number of players served by each table. Notice that the output must be listed in chronological order of the serving time. The waiting time must be rounded up to an integer minute(s). If one cannot get a table before the closing time, their information must NOT be printed.

Sample Input: 9 20:52:00 10 0 08:00:00 20 0 08:02:00 30 0 20:51:00 10 0 08:10:00 5 0 08:12:00 10 1 20:50:00 10 0 08:01:30 15 1 20:53:00 10 1 3 1 2 Sample Output: 08:00:00 08:00:00 0 08:01:30 08:01:30 0 08:02:00 08:02:00 0 08:12:00 08:16:30 5 08:10:00 08:20:00 10 20:50:00 20:50:00 0 20:51:00 20:51:00 0 20:52:00 20:52:00 0 3 3 2

代码语言:javascript
复制
#include <iostream>
#include <string.h>
#include <stdlib.h>
#include <stdio.h>
#include <math.h>
#include <algorithm>
#include <queue>

using namespace std;
#define INF 21*3600
#define MAX 10000
int CurrTime[MAX+5];
int numTable[MAX+5];//桌子被玩的次数
//用户的结构体
struct Player
{
    int startTime;//到达的时间
    int waitTime;//等待的时间
    int playTime;//玩耍的时间
}VipPlayer[MAX+5],OriPlayer[MAX+5];
int n;//n个人
int k,m;//桌子的数量,vip桌子的数量
int cmp(Player a,Player b) {return a.startTime<b.startTime;}//比较函数,快速排序
int VipNumber;//会员的人数
int OriNumber;//普通的人数
bool vipTag[MAX+5];//标记vip桌子
void printTime(int time)
{
    int hh,mm,ss;
    ss=time%60;
    mm=time/60%60;
    hh=time/3600;
    printf("%02d:%02d:%02d ",hh,mm,ss);
}
int main()
{
    scanf("%d",&n);
    int hh,mm,ss,time,tag;
    VipNumber=1;OriNumber=1;
    for(int i=1;i<=n;i++)
    {
        scanf("%d:%d:%d",&hh,&mm,&ss);
        int sum=hh*3600+mm*60+ss;
        scanf("%d%d",&time,&tag);
        if(time>120)//如果超过两个小时,要进行限制
            time=120;
        if(hh>=21) continue;//如果超出营业时间,要进行限制
        if(tag)//如果是vip
        {
            VipPlayer[VipNumber].startTime=sum;
            VipPlayer[VipNumber].waitTime=0;
            VipPlayer[VipNumber++].playTime=time;
        }
        else//如果不是
        {
            OriPlayer[OriNumber].startTime=sum;
            OriPlayer[OriNumber].waitTime=0;
            OriPlayer[OriNumber++].playTime=time;
        }
    }
    scanf("%d%d",&k,&m);//输入桌子数量和vip桌子数量
    int xx;memset(vipTag,0,sizeof(vipTag));
    memset(numTable,0,sizeof(numTable));
    for(int i=1;i<=m;i++)
    {
        scanf("%d",&xx);
        vipTag[xx]=1;
    }
    //对普通和vip进行排序
    sort(VipPlayer+1,VipPlayer+VipNumber,cmp);
    sort(OriPlayer+1,OriPlayer+OriNumber,cmp);
    int i=1,j=1;
    int index=-1;
    for(int i=1;i<=k;i++)
        CurrTime[i]=8*3600;
    while(i<VipNumber||j<OriNumber)
    {
        int minTime=INF,VipTime=INF,OriTime=INF;
        for(int p=1;p<=k;p++)
        {
            if(CurrTime[p]<minTime)
            {
                minTime=CurrTime[p];
                index=p;
            }
        }
        if(i>VipNumber&&j>OriNumber)
            break;
        if(i<VipNumber) {VipTime=max(VipPlayer[i].startTime,minTime);}
        if(j<OriNumber) {OriTime=max(OriPlayer[j].startTime,minTime);}
        bool VipServe=true;
        if(VipTime>OriTime&&OriTime<21*3600) {VipServe=false;}
        else if(OriTime>VipTime&&VipTime<21*3600) {VipServe=true;}
        else if(OriTime==VipTime&&OriTime<21*3600)
        {
            if(vipTag[index]||(!vipTag[index]&&VipPlayer[i].startTime<OriPlayer[j].startTime))
                VipServe=true;
            else
                VipServe=false;
        }
        else if(OriTime==21*3600&&VipTime==21*3600)
        {
            break;
        }
        //判断当前桌子可以为谁服务
        if(VipServe)
        {

            if(!vipTag[index])
            {
                for(int p=1;p<=k;p++)
                {
                    if(vipTag[p]&&CurrTime[p]==minTime)
                    {

                        index=p;
                    }
                }

            }
            VipPlayer[i].waitTime=VipTime;
            CurrTime[index]=VipTime+VipPlayer[i].playTime*60;
            numTable[index]++;

            printTime(VipPlayer[i].startTime);
            printTime(VipPlayer[i].waitTime);
            printf("%d\n",(VipPlayer[i].waitTime-VipPlayer[i].startTime+30)/60);
            i++;
        }
        else
        {
            OriPlayer[j].waitTime=OriTime;
            CurrTime[index]=OriTime+OriPlayer[j].playTime*60;
            numTable[index]++;

            printTime(OriPlayer[j].startTime);
            printTime(OriPlayer[j].waitTime);
            printf("%d\n",(OriPlayer[j].waitTime-OriPlayer[j].startTime+30)/60);
            j++;
        }


    }
    printf("%d",numTable[1]);
    for(int i=2;i<=k;i++)
        printf(" %d",numTable[i]);
    printf("\n");
    return 0;


}
本文参与 腾讯云自媒体分享计划,分享自作者个人站点/博客。
原始发表:2016-04-20 ,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体分享计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档