前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >POJ 3070 Fibonacci(矩阵快速幂)

POJ 3070 Fibonacci(矩阵快速幂)

作者头像
ShenduCC
发布2018-04-26 16:55:06
4920
发布2018-04-26 16:55:06
举报
文章被收录于专栏:算法修养算法修养算法修养

Fibonacci Time Limit: 1000MS Memory Limit: 65536K Total Submissions: 12271 Accepted: 8707 Description

In the Fibonacci integer sequence, F0 = 0, F1 = 1, and Fn = Fn − 1 + Fn − 2 for n ≥ 2. For example, the first ten terms of the Fibonacci sequence are:

0, 1, 1, 2, 3, 5, 8, 13, 21, 34, …

An alternative formula for the Fibonacci sequence is

.

Given an integer n, your goal is to compute the last 4 digits of Fn.

Input

The input test file will contain multiple test cases. Each test case consists of a single line containing n (where 0 ≤ n ≤ 1,000,000,000). The end-of-file is denoted by a single line containing the number −1.

Output

For each test case, print the last four digits of Fn. If the last four digits of Fn are all zeros, print ‘0’; otherwise, omit any leading zeros (i.e., print Fn mod 10000).

Sample Input

0 9 999999999 1000000000 -1 Sample Output

0 34 626 6875

#include <iostream>
#include <string.h>
#include <stdlib.h>
#include <algorithm>
#include <math.h>
#include <stdio.h>

using namespace std;
const int mod=10000;
typedef long long int LL;
LL n;
struct Node
{
    int a[3][3];
};
Node multiply(Node a,Node b)
{
    Node c;
    memset(c.a,0,sizeof(c.a));
    for(int i=0;i<2;i++)
    {
        for(int j=0;j<2;j++)
        {
            for(int k=0;k<2;k++)
            {
                (c.a[i][k]+=(a.a[i][j]*b.a[j][k])%mod)%=mod;
            }
        }
    }
    return c;
}
Node get(Node a,LL x)
{
    Node c;
    memset(c.a,0,sizeof(c.a));
    for(int i=0;i<2;i++)
        c.a[i][i]=1;
    for(x;x;x>>=1)
    {
        if(x&1) c=multiply(c,a);
        a=multiply(a,a);
    }
    return c;
}
int main()
{
    while(scanf("%lld",&n)!=EOF)
    {
        if(n==-1)
            break;
        if(n==0)
        {
            printf("0\n");
            continue;
        }
         Node a;
         a.a[0][0]=1;a.a[0][1]=1;
         a.a[1][0]=1;a.a[1][1]=0;
         a=get(a,n);
         printf("%d\n",a.a[0][1]);

    }
    return 0;
}
本文参与 腾讯云自媒体分享计划,分享自作者个人站点/博客。
原始发表:2016-04-22 ,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体分享计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档