前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >POJ 3150 Cellular Automaton(矩阵快速幂)

POJ 3150 Cellular Automaton(矩阵快速幂)

作者头像
ShenduCC
发布2018-04-26 16:55:25
5220
发布2018-04-26 16:55:25
举报
文章被收录于专栏:算法修养算法修养

Cellular Automaton Time Limit: 12000MS Memory Limit: 65536K Total Submissions: 3504 Accepted: 1421 Case Time Limit: 2000MS Description

A cellular automaton is a collection of cells on a grid of specified shape that evolves through a number of discrete time steps according to a set of rules that describe the new state of a cell based on the states of neighboring cells. The order of the cellular automaton is the number of cells it contains. Cells of the automaton of order n are numbered from 1 to n.

The order of the cell is the number of different values it may contain. Usually, values of a cell of order m are considered to be integer numbers from 0 to m − 1.

One of the most fundamental properties of a cellular automaton is the type of grid on which it is computed. In this problem we examine the special kind of cellular automaton — circular cellular automaton of order n with cells of order m. We will denote such kind of cellular automaton as n,m-automaton.

A distance between cells i and j in n,m-automaton is defined as min(|i − j|, n − |i − j|). A d-environment of a cell is the set of cells at a distance not greater than d.

On each d-step values of all cells are simultaneously replaced by new values. The new value of cell i after d-step is computed as a sum of values of cells belonging to the d-enviroment of the cell i modulo m.

The following picture shows 1-step of the 5,3-automaton.

The problem is to calculate the state of the n,m-automaton after k d-steps.

Input

The first line of the input file contains four integer numbers n, m, d, and k (1 ≤ n ≤ 500, 1 ≤ m ≤ 1 000 000, 0 ≤ d < n⁄2 , 1 ≤ k ≤ 10 000 000). The second line contains n integer numbers from 0 to m − 1 — initial values of the automaton’s cells.

Output

Output the values of the n,m-automaton’s cells after k d-steps.

Sample Input

sample input #1 5 3 1 1 1 2 2 1 2

sample input #2 5 3 1 10 1 2 2 1 2 Sample Output

sample output #1 2 2 2 2 1

sample output #2 2 0 0 2 2

这道题目的矩阵好找,但是由于n比较大,用n*n的矩阵再加上快速幂,是O(n^3*log k) 回超时。观察矩阵,发现矩阵是一个循环矩阵,无论矩阵取多少次方,矩阵的每一行相当于第一行向后推了一步,所以说是循环矩阵,这样我们只要计算矩阵的第一行就可以知道矩阵的其他行,所以只开一维数组效率就是O(n^2log k)

代码语言:javascript
复制
#include <iostream>
#include <string.h>
#include <stdlib.h>
#include <algorithm>
#include <math.h>
#include <stdio.h>

using namespace std;
typedef long long int LL;
int n,m,d,k;
struct Node
{
    LL a[505];
};
Node multiply(Node a,Node b)
{
    Node c;
    memset(c.a,0,sizeof(c.a));
    for(int i=0;i<n;i++)
    {
        int cnt=(n-i)%n;
        for(int j=0;j<n;j++)
        {
            (c.a[i]+=(a.a[j]*b.a[cnt++])%m)%=m;
            if(cnt==n) cnt=0;
        }
    }
    return c;
}
Node get(Node a,int x)
{
    Node c;
    memset(c.a,0,sizeof(c.a));
    c.a[0]=1;
    for(x;x;x>>=1)
    {
        if(x&1) c=multiply(c,a);
        a=multiply(a,a);
    }
    return c;
}
int main()
{
    scanf("%d%d%d%d",&n,&m,&d,&k);
    Node a;Node b;
    memset(a.a,0,sizeof(a.a));
    memset(b.a,0,sizeof(b.a));
    for(int i=0;i<n;i++)
       scanf("%lld",&b.a[i]);
    a.a[0]=1;
    for(int i=1;i<=d;i++)
      a.a[i]=a.a[n-i]=1;
    a=get(a,k);
    a=multiply(b,a);
    for(int i=0;i<n;i++)
       if(i==n-1) printf("%lld\n",a.a[i]);
       else printf("%lld ",a.a[i]);
    return 0;
}
本文参与 腾讯云自媒体分享计划,分享自作者个人站点/博客。
原始发表:2016-04-22 ,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体分享计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档