前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >HDU 1796 How many integers can you find(容斥原理)

HDU 1796 How many integers can you find(容斥原理)

作者头像
ShenduCC
发布2018-04-26 17:16:51
6520
发布2018-04-26 17:16:51
举报
文章被收录于专栏:算法修养算法修养

How many integers can you find

Time Limit: 12000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 6434    Accepted Submission(s): 1849

Problem Description

  Now you get a number N, and a M-integers set, you should find out how many integers which are small than N, that they can divided exactly by any integers in the set. For example, N=12, and M-integer set is {2,3}, so there is another set {2,3,4,6,8,9,10}, all the integers of the set can be divided exactly by 2 or 3. As a result, you just output the number 7.

Input

  There are a lot of cases. For each case, the first line contains two integers N and M. The follow line contains the M integers, and all of them are different from each other. 0<N<2^31,0<M<=10, and the M integer are non-negative and won’t exceed 20.

Output

  For each case, output the number.

Sample Input

代码语言:javascript
复制
12 2
2 3

Sample Output

代码语言:javascript
复制
7这道题目是给定了因子,而且还不是互质的,所以在容斥原理上,就不能简单想乘,要求最小公倍数LCM另外有可能因子为0#include <iostream>
#include <string.h>
#include <stdio.h>
#include <algorithm>
#include <stdlib.h>
#include <math.h>

using namespace std;
typedef long long int LL;
LL gcd(LL a,LL b)
{
	return b?gcd(b,a%b):a;
}
LL ans,a[15],n,m;
void dfs(int id,int flag,int lcm)
{
	lcm=a[id]/gcd(a[id],lcm)*lcm;
	if(flag)
		ans+=n/lcm;
	else
		ans-=n/lcm;
	for(int i=id+1;i<m;i++)
		dfs(i,!flag,lcm);
}
int main()
{
	while(cin>>n>>m)
	{
        n--;
		for(int i=0;i<m;i++)
		{
            scanf("%d",&a[i]);
			if(!a[i]) i--,m--;
		}
		ans=0;
		for(int i=0;i<m;i++)
			dfs(i,1,a[i]);
		printf("%lld\n",ans);
	}
	return 0;
}
本文参与 腾讯云自媒体分享计划,分享自作者个人站点/博客。
原始发表:2016-05-04 ,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体分享计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
目录
  • How many integers can you find
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档