前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >ZOJ 3332 Strange Country II

ZOJ 3332 Strange Country II

作者头像
ShenduCC
发布2018-04-26 17:18:44
5890
发布2018-04-26 17:18:44
举报
文章被收录于专栏:算法修养算法修养

Strange Country II


Time Limit: 1 Second      Memory Limit: 32768 KB      Special Judge


You want to visit a strange country. There are n cities in the country. Cities are numbered from 1 to n. The unique way to travel in the country is taking planes. Strangely, in this strange country, for every two cities A and B, there is a flight from A to B or from B to A, but not both. You can start at any city and you can finish your visit in any city you want. You want to visit each city exactly once. Is it possible?

Input

There are multiple test cases. The first line of input is an integer T (0 < T <= 100) indicating the number of test cases. Then T test cases follow. Each test case starts with a line containing an integer n (0 < n<= 100), which is the number of cities. Each of the next n * (n - 1) / 2 lines contains 2 numbers AB (0 < AB <= nA != B), meaning that there is a flight from city A to city B.

Output

For each test case:

  • If you can visit each city exactly once, output the possible visiting order in a single line please. Separate the city numbers by spaces. If there are more than one orders, you can output any one.
  • Otherwise, output "Impossible" (without quotes) in a single line.

Sample Input

代码语言:javascript
复制
3
1
2
1 2
3
1 2
1 3
2 3

Sample Output

代码语言:javascript
复制
1
1 2
1 2 3
dfs#include <iostream>
#include <string.h>
#include <stdlib.h>
#include <algorithm>
#include <math.h>
#include <stdio.h>

using namespace std;
int a[105][105];
int ans[105];
int vis[105];
int n;
bool res;
void dfs(int x,int cnt)
{
	if(cnt>n)
		return;
	if(res)
	{
		ans[cnt]=x;
		return;
	}
    if(cnt==n)
	{
		res=true;
		ans[cnt]=x;
		return;

	}
    for(int i=1;i<=n;i++)
	{
		if(a[x][i]&&!vis[i])
		{
			vis[i]=1;
			dfs(i,cnt+1);
			vis[i]=0;
			if(res)
			{
				ans[cnt]=x;
				return;
			}

		}
	}
}
int main()
{
	int t;
	int x,y;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d",&n);
		memset(a,0,sizeof(a));
		for(int i=1;i<=n*(n-1)/2;i++)
		{
			scanf("%d%d",&x,&y);
			a[x][y]=1;
		}
		memset(vis,0,sizeof(vis));
		res=false;
		for(int i=1;i<=n;i++)
		{
			vis[i]=1;
			dfs(i,1);
			vis[i]=0;
			if(res)
				break;
		}
		if(!res)
		{
           printf("Impossible\n");
		   continue;
		}
		for(int i=1;i<=n;i++)
		{
			if(i!=n)
			printf("%d ",ans[i]);
			else
				printf("%d",ans[i]);
		}
		printf("\n");
	}
	return 0;
}
本文参与 腾讯云自媒体分享计划,分享自作者个人站点/博客。
原始发表:2016-05-04 ,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体分享计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档