前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >UESTC 491 Tricks in Bits

UESTC 491 Tricks in Bits

作者头像
ShenduCC
发布2018-04-26 17:19:49
5850
发布2018-04-26 17:19:49
举报
文章被收录于专栏:算法修养算法修养

Tricks in Bits

Time Limit: 1000MS

Memory Limit: 65535KB

64bit IO Format: %lld & %llu

Submit Status

Description

Given N unsigned 64-bit integers, you can bitwise NOT each or not. Then you need to add operations selected from bitwise XORbitwise ORand bitwise AND, between any two successive integers and calculate the result. Your job is to make the result as small as possible.

Input

The first line of the input is T (no more than 1000), which stands for the number of test cases you need to solve.

Then T blocks follow. The first line of each block contains a single number N (1≤N≤100) indicating the number of unsigned 64-bit integers. Then n integers follow in the next line.

Output

For every test case, you should output Case #k: first, where k indicates the case number and counts from 1. Then output the answer.

Sample Input

2  3  1 2 3  2  3 6

Sample Output

Case #1: 0 

Case #2: 1

代码语言:javascript
复制
#include <iostream>
#include <string.h>
#include <stdlib.h>
#include <algorithm>
#include <stdio.h>
#include <math.h>

using namespace std;
typedef unsigned long long int LL;
int n;
LL ans;
LL MAX;
LL a[105];
LL min(LL a,LL b){return (a<b?a:b);}
void dfs(LL num,int cnt)
{
    if(ans==0)
        return;
    if(num==0)
    {
        ans=0;
        return;
    }
    if(cnt==n+1)
    {
        ans=min(ans,num);
        return;
    }
    dfs(num|(~a[cnt]),cnt+1);
    dfs(num&(~a[cnt]),cnt+1);
    dfs(num^(~a[cnt]),cnt+1);
    dfs(num|a[cnt],cnt+1);
    dfs(num&a[cnt],cnt+1);
    dfs(num^a[cnt],cnt+1);
}
int main()
{
    int t;
    scanf("%d",&t);
    int cas=0;
    while(t--)
    {
        scanf("%d",&n);
        for(int i=1;i<=n;i++)
            scanf("%llu",&a[i]);
        MAX=1;
		MAX<<=63;
		ans=MAX;
        dfs(a[1],2);
        dfs(~a[1],2);
        printf("Case #%d: %llu\n",++cas,ans);
    }
    return 0;
}
本文参与 腾讯云自媒体分享计划,分享自作者个人站点/博客。
原始发表:2016-05-04 ,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体分享计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档