前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >HDU 3578 Greedy Tino(双塔DP)

HDU 3578 Greedy Tino(双塔DP)

作者头像
ShenduCC
发布2018-04-26 17:24:36
4730
发布2018-04-26 17:24:36
举报
文章被收录于专栏:算法修养算法修养算法修养

Greedy Tino

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 1194    Accepted Submission(s): 393

Problem Description

  Tino wrote a long long story. BUT! in Chinese...   So I have to tell you the problem directly and discard his long long story. That is tino want to carry some oranges with "Carrying pole", and he must make two side of the Carrying pole are the same weight. Each orange have its' weight. So greedy tino want to know the maximum weight he can carry.

Input

The first line of input contains a number t, which means there are t cases of the test data.   for each test case, the first line contain a number n, indicate the number of oranges.   the second line contains n numbers, Wi, indicate the weight of each orange   n is between 1 and 100, inclusive. Wi is between 0 and 2000, inclusive. the sum of Wi is equal or less than 2000.

Output

For each test case, output the maximum weight in one side of Carrying pole. If you can't carry any orange, output -1. Output format is shown in Sample Output.

Sample Input

1
5
1 2 3 4 5

Sample Output

Case 1: 7
双塔DP注意如果有一个橘子是0,那么就符合条件dp[i][j] 表示第i个橘子,两边差值#include <iostream>
#include <string.h>
#include <stdlib.h>
#include <algorithm>
#include <math.h>
#include <stdio.h>

using namespace std;
int n;
int a[105];
int dp[105][4005];
int main()
{
	int t;
	scanf("%d",&t);
	int cas=0;
	while(t--)
	{
		scanf("%d",&n);
		int num=0;
		for(int i=1;i<=n;i++)
		{
			scanf("%d",&a[i]);
			if(a[i]==0)
				i--,n--,num++;
			
		}
		memset(dp,-1,sizeof(dp));
		dp[0][0+2000]=0;
		for(int i=1;i<=n;i++)
		{
			memcpy(dp[i],dp[i-1],sizeof(dp[i]));
			for(int j=-2000;j<=2000;j++)
			{
				
                if(dp[i-1][j+2000]==-1) continue;

				if(j<0)
				{
                    dp[i][j-a[i]+2000]=max(dp[i][j-a[i]+2000],dp[i-1][j+2000]+a[i]);
                    dp[i][j+a[i]+2000]=max(dp[i][j+a[i]+2000],dp[i-1][j+2000]+max(0,j+a[i]));
				}
				else
				{
					
					 dp[i][j+a[i]+2000]=max( dp[i][j+a[i]+2000],dp[i-1][j+2000]+a[i]);
                     dp[i][j-a[i]+2000]=max(dp[i][j-a[i]+2000],dp[i-1][j+2000]+max(0,a[i]-j));
				}
			}
		}
		
		if(dp[n][2000])
			printf("Case %d: %d\n",++cas,dp[n][2000]);
		else
		{
			if(num>=1)
				printf("Case %d: %d\n",++cas,0);
			else
			   printf("Case %d: %d\n",++cas,-1);
		}
	}
	return 0;
}
本文参与 腾讯云自媒体分享计划,分享自作者个人站点/博客。
原始发表:2016-05-07 ,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体分享计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
目录
  • Greedy Tino
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档