前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >HDU 5421 Victor and String(回文树)

HDU 5421 Victor and String(回文树)

作者头像
ShenduCC
发布2018-04-26 17:30:21
6950
发布2018-04-26 17:30:21
举报
文章被收录于专栏:算法修养算法修养

Victor and String

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 524288/262144 K (Java/Others)

Total Submission(s): 163    Accepted Submission(s): 78

Problem Description

Victor loves to play with string. He thinks a string is charming as the string is a palindromic string. Victor wants to play  times. Each time he will do one of following four operations. Operation 1 : add a char  to the beginning of the string. Operation 2 : add a char  to the end of the string. Operation 3 : ask the number of different charming substrings. Operation 4 : ask the number of charming substrings, the same substrings which starts in different location has to be counted. At the beginning, Victor has an empty string.

Input

The input contains several test cases, at most  cases. In each case, the first line has one integer  means the number of operations. The first number of next  line is the integer , meaning the type of operation. If = or , there will be a lowercase English letters followed. .

Output

For each query operation(operation 3 or 4), print the correct answer.

Sample Input

代码语言:javascript
复制
6
1 a
1 b
2 a
2 c
3
4
8
1 a
2 a
2 a
1 a
3
1 b
3
4

Sample Output

代码语言:javascript
复制
4
5
4
5
11
这道题目和简单的回文树应用不一样了,它是在两头加字符,不是从左到右只加一边。那么我们怎么解决这样的问题呢?首先s[]数组应该开到长度的两倍,然后以中间作为起始点,分别向两边扩展。然后last应该有两个指针,一个指向左边,一个指向右边另外也应该有两个指针表示两边数组的长度,距离中间的长度在加入新节点的时候,从左边插,和从右边插是一样的,只是有一点在插入一边的时候可能会应该回影响另一边的last指针。具体见代码#include <iostream>
#include <string.h>
#include <stdlib.h>
#include <algorithm>
#include <math.h>
#include <stdio.h>

using namespace std;
typedef long long int LL;
const int MAX=1e5+5;
char str[MAX];
int n;
struct Tree
{
    int next[2*MAX][26];
    int fail[2*MAX];
    int num[2*MAX];
    int len[2*MAX];
    int s[2*MAX];
    int last[2];
    int tot[2];
    LL p;
    int new_node(int x)
    {
        memset(next[p],0,sizeof(next[p]));
        num[p]=0;
        len[p]=x;
        return p++;
    }
    void init()
    {
        p=0;
        new_node(0);
        new_node(-1);
        last[0]=0;
        last[1]=0;
        tot[0]=MAX-5;
        tot[1]=MAX-6;
        fail[0]=1;
    }
    int get_fail(int x,int k)
    {
        s[tot[0]-1]=-1;s[tot[1]+1]=-1;
         while(s[tot[k]]!=s[tot[k]+(k?-1:1)*(len[x]+1)])
            x=fail[x];
         return x;
    }
    int add(int x,int k)
    {
        x-='a';
        s[tot[k]+=(k?1:-1)]=x;
        int cur=get_fail(last[k],k);
        if(!(last[k]=next[cur][x]))
        {
            int now=new_node(len[cur]+2);
            fail[now]=next[get_fail(fail[cur],k)][x];
            next[cur][x]=now;
            num[now]=num[fail[now]]+1;
            last[k]=now;
            if(len[last[k]]==tot[1]-tot[0]+1)  last[k^1]=last[k];
        }
        return num[last[k]];
    }
}tree;
int main()
{
    int x;char y[10];
    while(scanf("%d",&n)!=EOF)
    {
        tree.init();
        LL ans=0;
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&x);
            if(x==1)
            {
                scanf("%s",y);
                ans+=tree.add(y[0],0);
            }
            else if(x==2)
            {
                scanf("%s",y);
                ans+=tree.add(y[0],1);
            }

            else if(x==3)
                printf("%d\n",tree.p-2);
            else
                printf("%lld\n",ans);
        }
    }
    return 0;
}
本文参与 腾讯云自媒体分享计划,分享自作者个人站点/博客。
原始发表:2016-05-12 ,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体分享计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
目录
  • Victor and String
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档