前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >PAT 甲级 1003Emergency(Dijkstra最短路)

PAT 甲级 1003Emergency(Dijkstra最短路)

作者头像
ShenduCC
发布2018-04-26 17:31:40
5900
发布2018-04-26 17:31:40
举报
文章被收录于专栏:算法修养算法修养算法修养

1003. Emergency (25)

时间限制

400 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.

Input

Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (<= 500) - the number of cities (and the cities are numbered from 0 to N-1), M - the number of roads, C1 and C2 - the cities that you are currently in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c1, c2 and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C1 to C2.

Output

For each test case, print in one line two numbers: the number of different shortest paths between C1 and C2, and the maximum amount of rescue teams you can possibly gather. All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.

Sample Input

5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1

Sample Output

2 4

题目的意思要求求出最短路的个数,和点的权值最大的值

#include <iostream>
#include <string.h>
#include <stdlib.h>
#include <algorithm>
#include <math.h>
#include <stdio.h>
#include <queue>

using namespace std;
const int maxn=1e9;
struct Nod
{
  int value;
  int next;
  int weight;
}edge[505*2];
int head[505];
int tot;
void add(int x,int y,int z)
{
  edge[tot].value=y;
  edge[tot].weight=z;
  edge[tot].next=head[x];
  head[x]=tot++;
}
int vis[505];
int d[505];
int num[505];
int res[505];
int w[505];
int n,c1,c2,m;
struct Node
{
  int pos;
  int dis;
  Node(){};
  Node(int pos,int dis)
  {
    this->pos=pos;
    this->dis=dis;
  }
  friend bool operator <(Node a,Node b)
  {
    return a.dis>b.dis;
  }
};
void Dijkstra(int st)
{
  priority_queue<Node> q;
  q.push(Node(st,0));
  memset(vis,0,sizeof(vis));
  memset(num,0,sizeof(num));
  memset(res,0,sizeof(res));
  for(int i=0;i<=500;i++)
    d[i]=1e9;
  d[st]=0;num[st]=1;res[st]=w[st];
  while(!q.empty())
  {
    Node term=q.top();
    q.pop();
    if(vis[term.pos])
      continue;
    vis[term.pos]=1;
    for(int i=head[term.pos];i!=-1;i=edge[i].next)
    {
      int y=edge[i].value;
      if(d[y]>term.dis+edge[i].weight)
      {
        num[y]+=num[term.pos];
        res[y]=res[term.pos]+w[y];
        d[y]=term.dis+edge[i].weight;
        q.push(Node(edge[i].value,d[y]));
      }
      else if(d[y]==term.dis+edge[i].weight)
      {
                num[y]+=num[term.pos];
        res[y]=max(res[y],res[term.pos]+w[y]);
      }
    }
  }
}

int main()
{
  scanf("%d%d%d%d",&n,&m,&c1,&c2);
  for(int i=0;i<n;i++)
    scanf("%d",&w[i]);
  int x,y,z;
  memset(head,-1,sizeof(head));
  tot=0;
  for(int i=1;i<=m;i++)
  {
    scanf("%d%d%d",&x,&y,&z);
    add(x,y,z);
    add(y,x,z);
  }
  Dijkstra(c1);
  printf("%d %d\n",num[c2],res[c2]);
  return 0;
}
本文参与 腾讯云自媒体分享计划,分享自作者个人站点/博客。
原始发表:2016-05-26 ,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体分享计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
目录
  • 1003. Emergency (25)
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档