前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >PAT 1004 Counting Leaves

PAT 1004 Counting Leaves

作者头像
ShenduCC
发布2018-04-26 17:31:57
8580
发布2018-04-26 17:31:57
举报
文章被收录于专栏:算法修养算法修养

1004. Counting Leaves (30)

时间限制

400 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.

Input

Each input file contains one test case. Each case starts with a line containing 0 < N < 100, the number of nodes in a tree, and M (< N), the number of non-leaf nodes. Then M lines follow, each in the format:

代码语言:javascript
复制
ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 01.

Output

For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output "0 1" in a line.

Sample Input

代码语言:javascript
复制
2 1
01 1 02

Sample Output

代码语言:javascript
复制
0 1
代码语言:javascript
复制
题意要求求出每一层的叶子节点的个数,用BFS即可
代码语言:javascript
复制
#include <iostream>
#include <string.h>
#include <stdlib.h>
#include <stdio.h>
#include <algorithm>
#include <math.h>
#include <queue>

using namespace std;
#define MAX 100
int n,m,k;
struct Node
{
  int value;
  int next;
}edge[MAX*4];
int head[MAX+5];
int tot;
void add(int x,int y)
{
  edge[tot].value=y;
  edge[tot].next=head[x];
  head[x]=tot++;
}
int ans[1005];
int bfs()
{
    queue<pair<int,int> > q;
  q.push(make_pair(1,1));
  memset(ans,0,sizeof(ans));
  pair<int,int> term;
  int num=0;
  while(!q.empty())
  {
      term=q.front();
    q.pop();
    num=max(num,term.second);
    int tag=0;
    for(int i=head[term.first];i!=-1;i=edge[i].next)
    {
      int y=edge[i].value;
      q.push(make_pair(y,term.second+1));
      tag=1;
    }
    if(!tag)
      ans[term.second]++;
  }
  return num;
}
int main()
{
  int x,y;
  scanf("%d%d",&n,&m);
  memset(head,-1,sizeof(head));
  tot=0;
  for(int i=1;i<=m;i++)
  {
       scanf("%d%d",&x,&k);
     for(int j=1;j<=k;j++)
     {
          scanf("%d",&y);
      add(x,y);
     }
  }
  int num=bfs();
  for(int i=1;i<=num;i++)
  {
    if(i==num)
      printf("%d\n",ans[i]);
    else
    printf("%d ",ans[i]);
  }
  return 0;
}
本文参与 腾讯云自媒体分享计划,分享自作者个人站点/博客。
原始发表:2016-05-26 ,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体分享计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
目录
  • 1004. Counting Leaves (30)
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档