前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >PAT 1009 Product of Polynomials

PAT 1009 Product of Polynomials

作者头像
ShenduCC
发布2018-04-26 17:33:30
8280
发布2018-04-26 17:33:30
举报
文章被收录于专栏:算法修养算法修养算法修养

1009. Product of Polynomials (25)

时间限制

400 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

This time, you are supposed to find A*B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 ... NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10, 0 <= NK < ... < N2 < N1 <=1000.

Output Specification:

For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output

3 3 3.6 2 6.0 1 1.6

#include <iostream>
#include <string.h>
#include <stdlib.h>
#include <algorithm>
#include <math.h>
#include <stdio.h>
#include <string>
#include <vector>
#include <strstream>
#include <map>

using namespace std;
struct Node
{
    int x;
    double y;
}a[15],b[15];
double tag[2005];
int n1,n2;
int main()
{
    scanf("%d",&n1);
    for(int i=1;i<=n1;i++)
        scanf("%d%lf",&a[i].x,&a[i].y);
    scanf("%d",&n2);
    for(int i=1;i<=n2;i++)
        scanf("%d%lf",&b[i].x,&b[i].y);
    memset(tag,0,sizeof(tag));
    for(int i=1;i<=n1;i++)
    {
        for(int j=1;j<=n2;j++)
        {
            tag[a[i].x+b[j].x]+=a[i].y*b[j].y;
        }
    }
    int num=0;
    for(int i=2000;i>=0;i--)
    {
        if(tag[i]!=0)
            num++;
    }
    if(num==0)
    {
        printf("%d\n",num);
        return 0;
    }
    else
        printf("%d ",num);
    int cnt=0;
    for(int i=2000;i>=0;i--)
    {
        if(tag[i]!=0)
        {
            cnt++;
            if(cnt==num)
                printf("%d %.1f\n",i,tag[i]);
           else
                printf("%d %.1f ",i,tag[i]);
        }
    }
    return 0;

}
本文参与 腾讯云自媒体分享计划,分享自作者个人站点/博客。
原始发表:2016-05-26 ,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体分享计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
目录
  • 1009. Product of Polynomials (25)
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档