前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >PAT 1013 Battle Over Cities(并查集)

PAT 1013 Battle Over Cities(并查集)

作者头像
ShenduCC
发布2018-04-27 10:20:10
6270
发布2018-04-27 10:20:10
举报
文章被收录于专栏:算法修养算法修养

1013. Battle Over Cities (25)

时间限制

400 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of the cities connected. Given the map of cities which have all the remaining highways marked, you are supposed to tell the number of highways need to be repaired, quickly.

For example, if we have 3 cities and 2 highways connecting city1-city2 and city1-city3. Then if city1 is occupied by the enemy, we must have 1 highway repaired, that is the highway city2-city3.

Input

Each input file contains one test case. Each case starts with a line containing 3 numbers N (<1000), M and K, which are the total number of cities, the number of remaining highways, and the number of cities to be checked, respectively. Then M lines follow, each describes a highway by 2 integers, which are the numbers of the cities the highway connects. The cities are numbered from 1 to N. Finally there is a line containing K numbers, which represent the cities we concern.

Output

For each of the K cities, output in a line the number of highways need to be repaired if that city is lost.

Sample Input

代码语言:javascript
复制
3 2 3
1 2
1 3
1 2 3

Sample Output

代码语言:javascript
复制
1
0
0

简单的并查集应用:

代码语言:javascript
复制
#include <iostream>
#include <string.h>
#include <stdlib.h>
#include <algorithm>
#include <math.h>
#include <stdio.h>
#include <string>
#include <vector>
#include <strstream>
#include <map>

using namespace std;
struct Node
{
    int x;
    int y;
}edge[1005*1005];
int father[10005];
int find(int x)
{
    if(father[x]!=x) father[x]=find(father[x]);
    return father[x];
}
int n,m,k;
int a;
int main()
{
    scanf("%d%d%d",&n,&m,&k);
    for(int i=1;i<=m;i++)
        scanf("%d%d",&edge[i].x,&edge[i].y);

    for(int i=1;i<=k;i++)
    {
        scanf("%d",&a);
        for(int j=1;j<=n;j++)
            father[j]=j;
        for(int j=1;j<=m;j++)
        {
            if(edge[j].x==a||edge[j].y==a)
                continue;
            int fx=find(edge[j].x);
            int fy=find(edge[j].y);
            if(fx!=fy)
                father[fx]=fy;
        }
        int ans=0;
        for(int j=1;j<=n;j++)
        {
            if(j==a) continue;
            find(j);
            if(father[j]==j)
                ans++;
        }
        printf("%d\n",ans-1);
    }
    return 0;

}
本文参与 腾讯云自媒体分享计划,分享自作者个人站点/博客。
原始发表:2016-05-30 ,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体分享计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
目录
  • 1013. Battle Over Cities (25)
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档