前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >PAT 1016 Phone Bills(模拟)

PAT 1016 Phone Bills(模拟)

作者头像
ShenduCC
发布2018-04-27 10:23:54
8280
发布2018-04-27 10:23:54
举报
文章被收录于专栏:算法修养

1016. Phone Bills (25)

时间限制

400 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

A long-distance telephone company charges its customers by the following rules:

Making a long-distance call costs a certain amount per minute, depending on the time of day when the call is made. When a customer starts connecting a long-distance call, the time will be recorded, and so will be the time when the customer hangs up the phone. Every calendar month, a bill is sent to the customer for each minute called (at a rate determined by the time of day). Your job is to prepare the bills for each month, given a set of phone call records.

Input Specification:

Each input file contains one test case. Each case has two parts: the rate structure, and the phone call records.

The rate structure consists of a line with 24 non-negative integers denoting the toll (cents/minute) from 00:00 - 01:00, the toll from 01:00 - 02:00, and so on for each hour in the day.

The next line contains a positive number N (<= 1000), followed by N lines of records. Each phone call record consists of the name of the customer (string of up to 20 characters without space), the time and date (mm:dd:hh:mm), and the word "on-line" or "off-line".

For each test case, all dates will be within a single month. Each "on-line" record is paired with the chronologically next record for the same customer provided it is an "off-line" record. Any "on-line" records that are not paired with an "off-line" record are ignored, as are "off-line" records not paired with an "on-line" record. It is guaranteed that at least one call is well paired in the input. You may assume that no two records for the same customer have the same time. Times are recorded using a 24-hour clock.

Output Specification:

For each test case, you must print a phone bill for each customer.

Bills must be printed in alphabetical order of customers' names. For each customer, first print in a line the name of the customer and the month of the bill in the format shown by the sample. Then for each time period of a call, print in one line the beginning and ending time and date (dd:hh:mm), the lasting time (in minute) and the charge of the call. The calls must be listed in chronological order. Finally, print the total charge for the month in the format shown by the sample.

Sample Input:

代码语言:javascript
复制
10 10 10 10 10 10 20 20 20 15 15 15 15 15 15 15 20 30 20 15 15 10 10 10
10
CYLL 01:01:06:01 on-line
CYLL 01:28:16:05 off-line
CYJJ 01:01:07:00 off-line
CYLL 01:01:08:03 off-line
CYJJ 01:01:05:59 on-line
aaa 01:01:01:03 on-line
aaa 01:02:00:01 on-line
CYLL 01:28:15:41 on-line
aaa 01:05:02:24 on-line
aaa 01:04:23:59 off-line

Sample Output:

代码语言:javascript
复制
CYJJ 01
01:05:59 01:07:00 61 $12.10
Total amount: $12.10
CYLL 01
01:06:01 01:08:03 122 $24.40
28:15:41 28:16:05 24 $3.85
Total amount: $28.25
aaa 01
02:00:01 04:23:59 4318 $638.80
Total amount: $638.80

模拟:

代码语言:javascript
复制
#include <iostream>
#include <string.h>
#include <stdlib.h>
#include <algorithm>
#include <math.h>
#include <stdio.h>
#include <map>
#include <string>
#include <strstream>
#include <vector>

using namespace std;
typedef long long int LL;
typedef pair<int,int> p;
map<string,int> m;
vector<p> a[1005];
int cmp(const p &a,const p &b)
{
    return a.first<b.first;
}
struct Node
{
    string s;
}b[1005];
struct Node2
{
  int st;
  int ed;
  double mo;
}e[1005][1005];
int cmp2(const Node &a,const Node &b)
{
    return a.s<b.s;
}
int time(int d,int h,int m){return d*24*60+h*60+m;}
void fun(int time)
{
    int d=time/(24*60);
    time%=(24*60);
    int h=time/60;
    time%=60;
    int m=time;
    printf("%02d:%02d:%02d ",d,h,m);
}
int num[24];
int money(int time1,int time2)
{
    int time=time1%(24*60);
    int h=time/60;
    int m=time%60;
    int mon=0;
    while(time1<time2)
    {
        if(time1+60-m<=time2)
            mon+=(60-m)*num[h];
        else
        {
            mon+=(time2-time1)*num[h];
            break;
        }
        time1+=(60-m);
        h+=1;
        if(h>=24)
            h=0;
        m=0;
    }
    return mon;
}
string name,str;
int mo,dd,hh,mm;

int n;
int main()
{
    for(int i=0;i<24;i++)
        scanf("%d",&num[i]);
    scanf("%d",&n);
    m.clear();
  for(int i=0;i<=n;i++)
    a[i].clear();
    int cnt=0,cot=1,tag;
    for(int i=1;i<=n;i++)
    {
        cin>>name;
        scanf("%d:%d:%d:%d",&mo,&dd,&hh,&mm);
        cin>>str;
        if(str[1]=='f')
            tag=0;
        else
            tag=1;
        if(!m.count(name))
        {
            m[name]=cot++;
            b[cnt++].s=name;
        }
        a[m[name]].push_back(make_pair(time(dd,hh,mm),tag));
    }
    for(int i=0;i<cot;i++)
        sort(a[i].begin(),a[i].end(),cmp);
    sort(b,b+cnt,cmp2);
    for(int i=0;i<cnt;i++)
    {
        
    int tot=0;
        int pos=m[b[i].s];
        int st=-1,ed=-1;
        double res=0;
        for(int j=0;j<a[pos].size();j++)
        {
            if(a[pos][j].second==1)
                st=a[pos][j].first;
            if(a[pos][j].second==0)
            {
                if(st!=-1)
                {
                    ed=a[pos][j].first;
          e[i][tot].st=st;
          e[i][tot].ed=ed;
          e[i][tot++].mo=1.0*money(st,ed)/100;
          st=-1;
                }
            }
        }
    if(tot==0)
      continue;
    cout<<b[i].s<<" ";
        printf("%02d\n",mo);
    for(int j=0;j<tot;j++)
    {
      fun(e[i][j].st);
      fun(e[i][j].ed);
      printf("%d $%.2f\n",e[i][j].ed-e[i][j].st,e[i][j].mo);
      res+=e[i][j].mo;
    }
        printf("Total amount: $%.2f\n",res);
    }
    return 0;
}
本文参与 腾讯云自媒体同步曝光计划,分享自作者个人站点/博客。
原始发表:2016-05-30 ,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体同步曝光计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
目录
  • 1016. Phone Bills (25)
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档