前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >PAT 1002 A+B for Polynomials

PAT 1002 A+B for Polynomials

作者头像
ShenduCC
发布2018-04-27 10:31:09
5840
发布2018-04-27 10:31:09
举报
文章被收录于专栏:算法修养算法修养

1002. A+B for Polynomials (25)

时间限制

400 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

This time, you are supposed to find A+B where A and B are two polynomials.

Input

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 ... NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10,0 <= NK < ... < N2 < N1 <=1000.

Output

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output

3 2 1.5 1 2.9 0 3.2

include <iostream>
#include <string.h>
#include <stdlib.h>
#include <algorithm>
#include <math.h>
#include <stdio.h>
#include <string>
#include <vector>
#include <strstream>
#include <map>

using namespace std;
double b[1005];
int tag[1005];
int a[45];

int k;
int main()
{ 
  scanf("%d",&k);
  int x;double y;
  int cnt=0;
  memset(tag,0,sizeof(tag));
  for(int i=1;i<=k;i++)
  {
    scanf("%d",&x);
    scanf("%lf",&y);
    if(!tag[x])
    {
            b[x]=y;
      a[cnt++]=x;
      tag[x]=1;
    }
    else
            b[x]+=y;
    
  }
  scanf("%d",&k);
  for(int i=1;i<=k;i++)
  {
    scanf("%d%lf",&x,&y);
    if(!tag[x])
    {
      b[x]=y;
        a[cnt++]=x;
      tag[x]=1;
    }
    else
      b[x]+=y;
  }
  
  sort(a,a+cnt);
  int num=0,num2;
  for(int i=cnt-1;i>=0;i--)
    if(b[a[i]]!=0) {num++;num2=i;}
  if(num==0)
  printf("%d\n",num);
  else
    printf("%d ",num);
  for(int i=cnt-1;i>=0;i--)
  {
    if(b[a[i]]==0)
      continue;
    if(i==num2)
      printf("%d %.1f\n",a[i],b[a[i]]);
    else
        printf("%d %.1f ",a[i],b[a[i]]);
  }

  return 0;
}
本文参与 腾讯云自媒体分享计划,分享自作者个人站点/博客。
原始发表:2016-05-30 ,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体分享计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
目录
  • 1002. A+B for Polynomials (25)
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档