前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >PAT 甲级 1027 Colors in Mars

PAT 甲级 1027 Colors in Mars

作者头像
ShenduCC
发布2018-04-27 10:39:58
5540
发布2018-04-27 10:39:58
举报
文章被收录于专栏:算法修养

1027. Colors in Mars (20)

时间限制

400 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

People in Mars represent the colors in their computers in a similar way as the Earth people. That is, a color is represented by a 6-digit number, where the first 2 digits are for Red, the middle 2 digits for Green, and the last 2 digits for Blue. The only difference is that they use radix 13 (0-9 and A-C) instead of 16. Now given a color in three decimal numbers (each between 0 and 168), you are supposed to output their Mars RGB values.

Input

Each input file contains one test case which occupies a line containing the three decimal color values.

Output

For each test case you should output the Mars RGB value in the following format: first output "#", then followed by a 6-digit number where all the English characters must be upper-cased. If a single color is only 1-digit long, you must print a "0" to the left.

Sample Input

代码语言:javascript
复制
15 43 71

Sample Output

代码语言:javascript
复制
#123456
代码语言:javascript
复制
简单题:
代码语言:javascript
复制
#include <iostream>
#include <string.h>
#include <stdlib.h>
#include <stdio.h>
#include <math.h>
#include <algorithm>
#include <vector>

using namespace std;
int a,b,c;
char aa[14]={'0','1','2','3','4','5','6','7','8','9','A','B','C','D'};
void dfs(int x,int cnt)
{
  if(x<13)
  {
    if(cnt==0)
      printf("0");
    printf("%c",aa[x]);
    return;
  }
    dfs(x/13,cnt+1);
  printf("%c",aa[x%13]);
}
int main()
{
  scanf("%d%d%d",&a,&b,&c);
  printf("#");
  dfs(a,0);
  dfs(b,0);
  dfs(c,0);
  printf("\n");
  return 0;
}
本文参与 腾讯云自媒体同步曝光计划,分享自作者个人站点/博客。
原始发表:2016-05-31 ,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体同步曝光计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
目录
  • 1027. Colors in Mars (20)
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档