前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >UVALive 6933 Virus synthesis(回文树)

UVALive 6933 Virus synthesis(回文树)

作者头像
ShenduCC
发布2018-04-27 10:43:13
6170
发布2018-04-27 10:43:13
举报
文章被收录于专栏:算法修养算法修养

Viruses are usually bad for your health. How about ghting them with... other viruses? In this problem,

you need to nd out how to synthesize such good viruses.

We have prepared for you a set of strings of the letters A, G, T and C. They correspond to the

DNA nucleotide sequences of viruses that we want to synthesize, using the following operations:

• Adding a nucleotide either to the beginning or the end of the existing sequence.

• Replicating the sequence, reversing the copied piece, and gluing it either to the beginning or to

the end of the original (so that e.g., AGTC can become AGTCCTGA or CTGAAGTC).

We're concerned about efficiency, since we have very many such sequences, some of them very long.

Find a way to synthesize them in a minimum number of operations.

Input

The rst line of input contains the number of test cases T. The descriptions of the test cases follow:

Each test case consists of a single line containing a non-empty string. The string uses only the

capital letters `A', `C', `G' and `T' and is not longer than 100 000 characters.

Output

For each test case, output a single line containing the minimum total number of operations necessary

to construct the given sequence.

Sample Input

4

AAAA

AGCTTGCA

AAGGGGAAGGGGAA

AAACAGTCCTGACAAAAAAAAAAAAC

Sample Output

3

8

6

18

参考大牛的博客 http://www.cnblogs.com/clrs97/p/4700658.html

代码语言:javascript
复制
#include <iostream>
#include <string.h>
#include <algorithm>
#include <math.h>
#include <stdio.h>
#include <stdlib.h>
#include <map>


using namespace std;
typedef long long int LL;
const int maxn=1e5+5;
map<char,int> m;
int n;
char str[maxn];
int f[maxn];
struct Tree
{
    int next[maxn][4];
    int fail[maxn];
    int train[maxn];
    int len[maxn];
    int num[maxn];
    int cnt[maxn];
    int s[maxn];
    int last;
    int p;
    int n;
    int new_node(int x)
    {
        memset(next[p],0,sizeof(next[p]));
        len[p]=x;
        return p++;
    }
    void init()
    {
        p=0;
        new_node(0);
        new_node(-1);
        last=0;n=0;
        s[0]=-1;
        fail[0]=1;
    }
    int get_fail(int x)
    {
        while(s[n-len[x]-1]!=s[n])
            x=fail[x];
        return x;
    }
    int get_fail2(int x,int pos)
    {
        while(s[n-len[x]-1]!=s[n]||(len[x]+2)*2>len[pos])
            x=fail[x];
        return x;
    }
    void add(char xx)
    {
        int x=m[xx];
        s[++n]=x;
        int cur=get_fail(last);
        if(!(last=next[cur][x]))
        {
            int now=new_node(len[cur]+2);
			fail[now]=next[get_fail(fail[cur])][x];
			if(len[now]<=2)
				train[now]=fail[now];
			else
                train[now]=next[get_fail2(train[cur],now)][x];
            
            next[cur][x]=now;
            last=now;
        }
    }
}tree;
int ans;
int q[maxn];
int rear,head;
int main()
{
    int t;
    scanf("%d",&t);
    m['A']=0;m['C']=1;m['G']=2;m['T']=3;
    while(t--)
    {
        scanf("%s",str);
        int len=strlen(str);
        tree.init();
        ans=len;
        for(int i=0;i<len;i++)
        {
            tree.add(str[i]);
        }
        memset(f,0,sizeof(f));
        for(int i=2;i<tree.p;i++)
        {
            if(tree.len[i]&1)
                f[i]=tree.len[i];
        }
        f[0]=1;
        q[0]=0;
        head=0;rear=1;
        int x,y;
        while(head<rear)
        {
            x=q[head++];
            for(int i=0;i<4;i++)
            {
                if(tree.next[x][i])
                {
                     y=tree.next[x][i];
                    f[y]=f[x]+1;
                    f[y]=min(f[y],tree.len[y]/2-tree.len[tree.train[y]]+f[tree.train[y]]+1);
                    ans=min(ans,len-tree.len[y]+f[y]);
					q[rear++]=y;
                }
                
            }
        }
        printf("%d\n",ans);
    }
    return 0;
}
本文参与 腾讯云自媒体分享计划,分享自作者个人站点/博客。
原始发表:2016-05-31 ,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体分享计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档