Eclipse 报错 “Dynamic Web Module 3.1 requires Java 1.7 or newer”第一步第二步第三步其他问题

当我在Eclipse里面编写Spring项目代码的时候出现了一个错误。

Dynamic Web Module 3.1 requires Java 1.7 or newer.

错误提示

经过下面几步可以解决这个问题。

第一步

确定你的Java项目配置为1.7以上版本。右键project > Properties > Java Compiler 然后设置 “Compiler compliance level” 为 1.7。

设置项目Java编译器兼容级别大于等于1.7

第二步

设置编译库的JRE版本大于等于1.7。

默认JRE库

修改为1.7及以上版本

第三步

修改Project Facets中的Java版本大于等于1.7。

修改Project Facets

其他问题

修改pom.xml

如果你是maven项目可以添加如下代码到你的pom.xml

<build>
    <plugins>
        <plugin>
        <groupId>org.apache.maven.plugins</groupId>
        <artifactId>maven-compiler-plugin</artifactId>
        <version>3.1</version>
        <configuration>
            <source>1.7</source>
            <target>1.7</target>
        </configuration>
    </plugin>
    </plugins>
</build>

修改项目配置文件

修改org.eclipse.wst.common.project.facet.core.xml文件。它保存在<project_folder>/.settings/org.eclipse.wst.common.project.facet.core.xml。

<?xml version="1.0" encoding="UTF-8"?>
<faceted-project>
  <fixed facet="wst.jsdt.web"/>
  <installed facet="jst.jaxrs" version="2.0"/>
  <installed facet="wst.jsdt.web" version="1.0"/>
  <installed facet="java" version="1.8"/>
  <installed facet="jst.web" version="3.0"/>
</faceted-project>

将<installed facet="jst.web" version="3.1"/>修改为上面3.0。

本文参与腾讯云自媒体分享计划,欢迎正在阅读的你也加入,一起分享。

发表于

我来说两句

0 条评论
登录 后参与评论

相关文章

来自专栏岑玉海

部署zookeeper集群

1.把zookeeper.tar.gz解压之后,移动到/usr目录下 2.首先要给zookeeper之间的每个节点的ssh设置无密码登陆  3.在zookeep...

3556
来自专栏实战docker

Docker下dubbo开发,三部曲之三:java开发

在前两章《Docker下dubbo开发,三部曲之一:极速体验》和《Docker下dubbo开发,三部曲之二:本地环境搭建》中,我们体验了dubbo环境搭建以及服...

2155
来自专栏性能与架构

高级的 Redis Java客户端 - Lettuce

1.5K4
来自专栏Python专栏

176条DevOps人员常用的linux命令速查表,收藏了慢慢看

1112
来自专栏Youngxj

Kali linux中安装虚拟机VMware10

1724
来自专栏世界第一语言是java

linux下tengine2.2.0编译安装、开机启动、反向代理配置及健康检查

3113
来自专栏架构师之旅

Linux文件权限与目录配置

一、linux文件属性 用户组概念:假如主机有两个团体,第一个团体名为projecta,里面有class1,class2,class3;第二个团体名为proje...

1986
来自专栏xingoo, 一个梦想做发明家的程序员

[大数据之Sqoop] —— Sqoop初探

Sqoop是一款用于把关系型数据库中的数据导入到hdfs中或者hive中的工具,当然也支持把数据从hdfs或者hive导入到关系型数据库中。 Sqoop也...

2609
来自专栏云计算教程系列

在Debian 8上使用Apt-Get安装Java

安装Java的最简单方法是使用Debian打包的版本。具体来说,这将安装OpenJDK 8,这是最新推荐的版本。

1954
来自专栏jeremy的技术点滴

使用阿里云API刷新CDN缓存

7466

扫码关注云+社区