Ubuntu 16.04 安装Hyperledger/Fabric 1.1.0 Preview

前提,安装docker, curl, go,nodejs,jdk,参考https://my.oschina.net/u/1760711/blog/1530513

1. 下载 运行 https://github.com/hyperledger/fabric/blob/master/scripts/bootstrap.sh

$ cd ~/dev/hyperledger
$ ./bootstrap.sh

这个脚本中内置了一个版本,我运行的时候是1.0.4。

2. 设置GOPATH为/opt/gopath,因为example中很多yaml写死了这个路径,所以下面执行git clone目录应为 /opt/gopath/src/github.com/hyperledger/

git clone https://github.com/hyperledger/fabric.git
git clone https://github.com/hyperledger/fabric-ca.git

3. Run e2e test 

cd /opt/gopath/src/github.com/hyperledger/fabric/examples/e2e_cli/
./network_setup.sh up

本文参与腾讯云自媒体分享计划,欢迎正在阅读的你也加入,一起分享。

发表于

我来说两句

0 条评论
登录 后参与评论

扫码关注云+社区