前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >POJ1286 Necklace of Beads(Polya定理)

POJ1286 Necklace of Beads(Polya定理)

作者头像
attack
发布2018-07-27 15:17:40
2130
发布2018-07-27 15:17:40
举报

Time Limit: 1000MS

Memory Limit: 10000K

Total Submissions: 9359

Accepted: 3862

Description

Beads of red, blue or green colors are connected together into a circular necklace of n beads ( n < 24 ). If the repetitions that are produced by rotation around the center of the circular necklace or reflection to the axis of symmetry are all neglected, how many different forms of the necklace are there? 

Input

The input has several lines, and each line contains the input data n. 

-1 denotes the end of the input file. 

Output

The output should contain the output data: Number of different forms, in each line correspondent to the input data.

Sample Input

4
5
-1

Sample Output

21
39

Source

Xi'an 2002

哈哈我是来骗访问量的。这题和上一题一毛一样

只不过需要把颜色数改为$3$然后换成LLd

上一篇:https://cloud.tencent.com/developer/article/1168590

#include<algorithm>
#include<iostream>
#include<cstdio> 
#define int long long 
using namespace std;
int C = 3, N;
int fastpow(int a, int p) {
    int base = 1;
    while(p) {
        if(p & 1) base = base * a;
        a = a * a; p >>= 1;
    }
    return base;
}
main() {
    while(cin >> N) {
        if(N == -1) break;
        if(N <= 0) {printf("0\n"); continue;}
        int ans = 0;
        for(int i = 1; i <= N; i++) ans += fastpow(C, __gcd(i, N));
        if(N & 1) ans = ans + N * fastpow(C, (N + 1) / 2);
        else ans = ans + N / 2  * (fastpow(C, (N + 2) / 2) + fastpow(C, N / 2));
        cout << ans / 2 / N << endl;
    }
}
本文参与 腾讯云自媒体分享计划,分享自作者个人站点/博客。
原始发表:2018-07-11 ,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体分享计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档