前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >PAT Advanced 1065

PAT Advanced 1065

作者头像
chain
发布2018-08-02 15:08:59
2540
发布2018-08-02 15:08:59
举报
文章被收录于专栏:开发 & 算法杂谈

1065. A+B and C (64bit) (20)

时间限制

100 ms

内存限制

32000 kB

代码长度限制

16000 B

判题程序

Standard

作者

HOU, Qiming

Given three integers A, B and C in [-263, 263], you are supposed to tell whether A+B > C.

Input Specification:

The first line of the input gives the positive number of test cases, T (<=10). Then T test cases follow, each consists of a single line containing three integers A, B and C, separated by single spaces.

Output Specification:

For each test case, output in one line "Case #X: true" if A+B>C, or "Case #X: false" otherwise, where X is the case number (starting from 1).

Sample Input:

代码语言:javascript
复制
3
1 2 3
2 3 4
9223372036854775807 -9223372036854775808 0

Sample Output:

代码语言:javascript
复制
Case #1: false
Case #2: true
Case #3: false
代码语言:javascript
复制
代码语言:javascript
复制
#include<stdio.h>
typedef  long long int LONG;
int main()
{
	int n;
	scanf("%d",&n);
	LONG a,b,c,temp;
	int flag=0,count=0;
	while(scanf("%lld %lld %lld",&a,&b,&c)!=EOF)
	{
		count++;
		temp=a+b;
		/* 关键点是大数相加会溢出 */
		if(a>0 && b>0 && temp<=0)
			flag=1;
		else if(a<0 && b<0 && temp>=0)
			flag=0;
		else
			flag= (temp>c);

		if(flag)
			printf("Case #%d: true\n",count);
		else
			printf("Case #%d: false\n",count);
	}
	return 0;
}
本文参与 腾讯云自媒体同步曝光计划,分享自作者个人站点/博客。
原始发表:2013年10月13日,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体同步曝光计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
目录
  • 1065. A+B and C (64bit) (20)
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档