-source 1.7 中不支持 lambda 表达式(请使用 -source 8 或更高版本以启用 lambda 表达式)

1.idea 的sdk,jdk也已经设置为了java1.8

2.本地jvm环境也是1.8


还是这样


后来发现是我的maven的配置的java环境不是1.8。选择idea使用的maven的配置文件

打开H:\apache-maven-3.3.9-repository下的setting.xml,看到原来配置的是java1.7,更改为1.8就好了。

本文参与腾讯云自媒体分享计划,欢迎正在阅读的你也加入,一起分享。

发表于

我来说两句

0 条评论
登录 后参与评论

扫码关注云+社区

领取腾讯云代金券