专栏首页乐沙弥的世界使用yum快速部署Oracle安装环境(11g)

使用yum快速部署Oracle安装环境(11g)

    基于Linux安装过Oracle的童鞋们都应该清楚,安装Oracle的确是一件比较费时费力的差事,因为仅仅是前期的rpm包,内核参数,创建用户等等这些个步骤都让那些新手不免眼花缭乱,一不留神,就导致最终的安装过程中报错而不得不从头来过。现在基于Oracle Linux,Oracle仅仅需要通过安装oracle-rdbms-server-11gR2-preinstall RPM包即可全部搞定其余未安装的RPM包,解决之间的依赖关系,配置内核参数等等。客官,正在基于Oracle Linux 安装Oralce 11g?那就接着往下看。

1、oracle-rdbms-server-11gR2-preinstall RPM 软件包的功能

a、 Automatically downloading and installing any additional software packages and specific package versions needed for installing Oracle Grid Infrastructure and Oracle Database 12 c Release 1 (12.1) or 11g Release 2 (11.2.0.3), with package dependencies resolved via yum or up2date capabilities.

b、Creating the user oracle and the groups oinstall (for OraInventory) and dba (for OSDBA), which are used during database installation. (For security purposes, this user has no password by default and cannot log in remotely. To enable remote login, please set a password using the passwd tool.)

c、Modifying kernel parameters in /etc/sysctl.conf to change settings for shared memory, semaphores, the maximum number of file descriptors, and so on. d、Setting hard and soft shell resource limits in /etc/security/limits.conf, such as the locked-in memory address space, the number of open files, the number of processes, and core file size.

e、Setting numa=off in the kernel for x86_64 machines.

2、操作步骤 a、确保网络畅通,即可连接到Internet。 b、已经安装了yum包管理工具。 c、切换到目录 /etc/yum.repos.d/ d、获取配置文件并进行相应修改wget http://public-yum.oracle.com/public-yum-ol6.repo(所需安装版本项下字段enabled=0更改为enabled=1) e、使用yum安装oracle-rdbms-server-11gR2-preinstall包(oracle-rdbms-server-11gR2-preinstall) f、校验内核修改日志及原文件备份情况

-- Author: Leshami -- Blog  : http://blog.csdn.net/leshami

3、实战演习 a、检查网络环境,确保网络畅通 [root@oel63 ~]# cat /etc/issue Oracle Linux Server release 6.3 Kernel \r on an \m [root@oel63 ~]# ping www.baidu.com PING www.a.shifen.com (115.239.211.110) 56(84) bytes of data. 64 bytes from 115.239.211.110: icmp_seq=1 ttl=54 time=39.2 ms 64 bytes from 115.239.211.110: icmp_seq=2 ttl=54 time=42.2 ms

b、检查yum是否已安装 [root@oel63 ~]# rpm -qa | grep yum yum-utils-1.1.30-14.el6.noarch PackageKit-yum-plugin-0.5.8-20.0.1.el6.x86_64 yum-rhn-plugin-0.9.1-40.0.1.el6.noarch yum-plugin-security-1.1.30-14.el6.noarch yum-3.2.29-30.0.1.el6.noarch PackageKit-yum-0.5.8-20.0.1.el6.x86_64 yum-metadata-parser-1.1.2-16.el6.x86_64

c、切换到目录 /etc/yum.repos.d/ [root@oel63 ~]# cd /etc/yum.repos.d/

d、获取配置文件并进行相应修改 [root@oel63 yum.repos.d]# wget http://public-yum.oracle.com/public-yum-ol6.repo --2014-05-16 14:41:51--  http://public-yum.oracle.com/public-yum-ol6.repo Resolving public-yum.oracle.com... 184.51.198.32, 184.51.198.8, 184.51.198.65 Connecting to public-yum.oracle.com|184.51.198.32|:80... connected. HTTP request sent, awaiting response... 200 OK Length: 4233 (4.1K) [text/plain] Saving to: “public-yum-ol6.repo”

100%[======================================>] 4,233       --.-K/s   in 0.001s 

2014-05-16 14:41:51 (5.76 MB/s) - “public-yum-ol6.repo” saved [4233/4233

[root@oel63 yum.repos.d]# ls -hltr total 8.0K -rw-r--r--. 1 root root 4.2K Nov 25 04:58 public-yum-ol6.repo

[root@oel63 yum.repos.d]# vi public-yum-ol6.repo #本环境为Oracle Linux 6.3,因此修改了以下2个部分。即将需要安装的部分的enabled的值置为1 [ol6_u3_base] name=Oracle Linux $releasever Update 3 installation media copy ($basearch) baseurl=http://public-yum.oracle.com/repo/OracleLinux/OL6/3/base/$basearch/ gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-oracle gpgcheck=1 enabled=1

[ol6_UEK_base] name=Unbreakable Enterprise Kernel for Oracle Linux $releasever ($basearch) baseurl=http://public-yum.oracle.com/repo/OracleLinux/OL6/UEK/base/$basearch/ gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-oracle gpgcheck=1 enabled=1

e、使用yum安装oracle-rdbms-server-11gR2-preinstall包

### 对于非Oracle Linux版本,如CentOS,yum时报如下错误,可以使用--nogpgcheck来跳过gpg校验 leshami@20170302

Retrieving key from file:///etc/pki/rpm-gpg/RPM-GPG-KEY-oracle

[root@oel63 yum.repos.d]# yum install oracle-rdbms-server-11gR2-preinstall Loaded plugins: refresh-packagekit, security ol6_UEK_base                                               | 1.2 kB     00:00     ol6_UEK_base/primary                                       | 1.0 MB     00:01     ol6_UEK_base                                                                36/36 ol6_UEK_latest                                             | 1.2 kB     00:00     ol6_latest                                                 | 1.4 kB     00:00     ol6_u3_base                                                | 1.4 kB     00:00     ol6_u3_base/primary                                        | 2.7 MB     00:11     ol6_u3_base                                                             8452/8452 Setting up Install Process Resolving Dependencies --> Running transaction check ---> Package oracle-rdbms-server-11gR2-preinstall.x86_64 0:1.0-9.el6 will be installed --> Processing Dependency: gcc for package: oracle-rdbms-server-11gR2-preinstall-1.0-9.el6.x86_64 --> Processing Dependency: gcc-c++ for package: oracle-rdbms-server-11gR2-preinstall-1.0-9.el6.x86_64 --> Processing Dependency: compat-libcap1 for package: oracle-rdbms-server-11gR2-preinstall-1.0-9.el6.x86_64 --> Processing Dependency: ksh for package: oracle-rdbms-server-11gR2-preinstall-1.0-9.el6.x86_64 --> Processing Dependency: libaio-devel for package: oracle-rdbms-server-11gR2-preinstall-1.0-9.el6.x86_64 --> Processing Dependency: glibc-devel for package: oracle-rdbms-server-11gR2-preinstall-1.0-9.el6.x86_64 --> Processing Dependency: compat-libstdc++-33 for package: oracle-rdbms-server-11gR2-preinstall-1.0-9.el6.x86_64 --> Processing Dependency: libstdc++-devel for package: oracle-rdbms-server-11gR2-preinstall-1.0-9.el6.x86_64 --> Running transaction check ---> Package compat-libcap1.x86_64 0:1.10-1 will be installed ---> Package compat-libstdc++-33.x86_64 0:3.2.3-69.el6 will be installed ---> Package gcc.x86_64 0:4.4.7-4.el6 will be installed --> Processing Dependency: libgomp = 4.4.7-4.el6 for package: gcc-4.4.7-4.el6.x86_64 --> Processing Dependency: cpp = 4.4.7-4.el6 for package: gcc-4.4.7-4.el6.x86_64 --> Processing Dependency: libgcc >= 4.4.7-4.el6 for package: gcc-4.4.7-4.el6.x86_64 --> Processing Dependency: cloog-ppl >= 0.15 for package: gcc-4.4.7-4.el6.x86_64 ---> Package gcc-c++.x86_64 0:4.4.7-4.el6 will be installed --> Processing Dependency: libstdc++ = 4.4.7-4.el6 for package: gcc-c++-4.4.7-4.el6.x86_64 --> Processing Dependency: libmpfr.so.1()(64bit) for package: gcc-c++-4.4.7-4.el6.x86_64 ---> Package glibc-devel.x86_64 0:2.12-1.132.el6_5.1 will be installed --> Processing Dependency: glibc = 2.12-1.132.el6_5.1 for package: glibc-devel-2.12-1.132.el6_5.1.x86_64 --> Processing Dependency: glibc-headers = 2.12-1.132.el6_5.1 for package: glibc-devel-2.12-1.132.el6_5.1.x86_64 --> Processing Dependency: glibc-headers for package: glibc-devel-2.12-1.132.el6_5.1.x86_64 ---> Package ksh.x86_64 0:20120801-10.el6_5.4 will be installed ---> Package libaio-devel.x86_64 0:0.3.107-10.el6 will be installed ---> Package libstdc++-devel.x86_64 0:4.4.7-4.el6 will be installed --> Running transaction check ---> Package cloog-ppl.x86_64 0:0.15.7-1.2.el6 will be installed --> Processing Dependency: libppl_c.so.2()(64bit) for package: cloog-ppl-0.15.7-1.2.el6.x86_64 --> Processing Dependency: libppl.so.7()(64bit) for package: cloog-ppl-0.15.7-1.2.el6.x86_64 ---> Package cpp.x86_64 0:4.4.7-4.el6 will be installed ---> Package glibc.x86_64 0:2.12-1.80.el6 will be updated --> Processing Dependency: glibc = 2.12-1.80.el6 for package: glibc-common-2.12-1.80.el6.x86_64 ---> Package glibc.x86_64 0:2.12-1.132.el6_5.1 will be an update ---> Package glibc-headers.x86_64 0:2.12-1.132.el6_5.1 will be installed --> Processing Dependency: kernel-headers >= 2.2.1 for package: glibc-headers-2.12-1.132.el6_5.1.x86_64 --> Processing Dependency: kernel-headers for package: glibc-headers-2.12-1.132.el6_5.1.x86_64 ---> Package libgcc.x86_64 0:4.4.6-4.el6 will be updated ---> Package libgcc.x86_64 0:4.4.7-4.el6 will be an update ---> Package libgomp.x86_64 0:4.4.6-4.el6 will be updated ---> Package libgomp.x86_64 0:4.4.7-4.el6 will be an update ---> Package libstdc++.x86_64 0:4.4.6-4.el6 will be updated ---> Package libstdc++.x86_64 0:4.4.7-4.el6 will be an update ---> Package mpfr.x86_64 0:2.4.1-6.el6 will be installed --> Running transaction check ---> Package glibc-common.x86_64 0:2.12-1.80.el6 will be updated ---> Package glibc-common.x86_64 0:2.12-1.132.el6_5.1 will be an update ---> Package kernel-uek-headers.x86_64 0:2.6.32-400.34.5.el6uek will be installed ---> Package ppl.x86_64 0:0.10.2-11.el6 will be installed --> Finished Dependency Resolution

Dependencies Resolved

=================================================================================================  Package                                Arch       Version                 Repository       Size ================================================================================================= Installing:  oracle-rdbms-server-11gR2-preinstall   x86_64     1.0-9.el6               ol6_latest       17 k Installing for dependencies:  cloog-ppl                              x86_64     0.15.7-1.2.el6          ol6_latest       93 k  compat-libcap1                         x86_64     1.10-1                  ol6_latest       17 k  compat-libstdc++-33                    x86_64     3.2.3-69.el6            ol6_latest      183 k  cpp                                    x86_64     4.4.7-4.el6             ol6_latest      3.7 M  gcc                                    x86_64     4.4.7-4.el6             ol6_latest       10 M  gcc-c++                                x86_64     4.4.7-4.el6             ol6_latest      4.7 M  glibc-devel                            x86_64     2.12-1.132.el6_5.1      ol6_latest      977 k  glibc-headers                          x86_64     2.12-1.132.el6_5.1      ol6_latest      608 k  kernel-uek-headers                     x86_64     2.6.32-400.34.5.el6uek  ol6_latest      737 k  ksh                                    x86_64     20120801-10.el6_5.4     ol6_latest      756 k  libaio-devel                           x86_64     0.3.107-10.el6          ol6_latest       13 k  libstdc++-devel                        x86_64     4.4.7-4.el6             ol6_latest      1.6 M  mpfr                                   x86_64     2.4.1-6.el6             ol6_latest      156 k  ppl                                    x86_64     0.10.2-11.el6           ol6_latest      1.3 M Updating for dependencies:  glibc                                  x86_64     2.12-1.132.el6_5.1      ol6_latest      3.8 M  glibc-common                           x86_64     2.12-1.132.el6_5.1      ol6_latest       14 M  libgcc                                 x86_64     4.4.7-4.el6             ol6_latest      100 k  libgomp                                x86_64     4.4.7-4.el6             ol6_latest      118 k  libstdc++                              x86_64     4.4.7-4.el6             ol6_latest      292 k

Transaction Summary ================================================================================================= Install      15 Package(s) Upgrade       5 Package(s)

Total download size: 43 M Is this ok [y/N]: y Downloading Packages: (1/20): cloog-ppl-0.15.7-1.2.el6.x86_64.rpm                             |  93 kB     00:00     (2/20): compat-libcap1-1.10-1.x86_64.rpm                                |  17 kB     00:00     (3/20): compat-libstdc++-33-3.2.3-69.el6.x86_64.rpm                     | 183 kB     00:00     (4/20): cpp-4.4.7-4.el6.x86_64.rpm                                      | 3.7 MB     00:08     (5/20): gcc-4.4.7-4.el6.x86_64.rpm                                      |  10 MB     00:26     (6/20): gcc-c++-4.4.7-4.el6.x86_64.rpm                                  | 4.7 MB     00:19     (7/20): glibc-2.12-1.132.el6_5.1.x86_64.rpm                             | 3.8 MB     00:08     (8/20): glibc-common-2.12-1.132.el6_5.1.x86_64.rpm                      |  14 MB     00:32     (9/20): glibc-devel-2.12-1.132.el6_5.1.x86_64.rpm                       | 977 kB     00:01     (10/20): glibc-headers-2.12-1.132.el6_5.1.x86_64.rpm                    | 608 kB     00:00     (11/20): kernel-uek-headers-2.6.32-400.34.5.el6uek.x86_64.rpm           | 737 kB     00:01     (12/20): ksh-20120801-10.el6_5.4.x86_64.rpm                             | 756 kB     00:01     (13/20): libaio-devel-0.3.107-10.el6.x86_64.rpm                         |  13 kB     00:00     (14/20): libgcc-4.4.7-4.el6.x86_64.rpm                                  | 100 kB     00:00     (15/20): libgomp-4.4.7-4.el6.x86_64.rpm                                 | 118 kB     00:00     (16/20): libstdc++-4.4.7-4.el6.x86_64.rpm                               | 292 kB     00:00     (17/20): libstdc++-devel-4.4.7-4.el6.x86_64.rpm                         | 1.6 MB     00:03     (18/20): mpfr-2.4.1-6.el6.x86_64.rpm                                    | 156 kB     00:00     (19/20): oracle-rdbms-server-11gR2-preinstall-1.0-9.el6.x86_64.rpm      |  17 kB     00:00     (20/20): ppl-0.10.2-11.el6.x86_64.rpm                                   | 1.3 MB     00:02     ------------------------------------------------------------------------------------------------------------ Total                                                                   396 kB/s |  43 MB     01:51     warning: rpmts_HdrFromFdno: Header V3 RSA/SHA256 Signature, key ID ec551f03: NOKEY Retrieving key from file:///etc/pki/rpm-gpg/RPM-GPG-KEY-oracle Importing GPG key 0xEC551F03:  Userid : Oracle OSS group (Open Source Software group) <build@oss.oracle.com>  Package: 6:oraclelinux-release-6Server-3.0.2.x86_64 (@anaconda-OracleLinuxServer-201206261930.x86_64/6.3)  From   : /etc/pki/rpm-gpg/RPM-GPG-KEY-oracle Is this ok [y/N]: y Running rpm_check_debug Running Transaction Test Transaction Test Succeeded Running Transaction   Updating   : libgcc-4.4.7-4.el6.x86_64                                                   1/25   Updating   : glibc-2.12-1.132.el6_5.1.x86_64                                             2/25   Updating   : glibc-common-2.12-1.132.el6_5.1.x86_64                                      3/25   Updating   : libstdc++-4.4.7-4.el6.x86_64                                                4/25   Installing : libstdc++-devel-4.4.7-4.el6.x86_64                                          5/25   Installing : mpfr-2.4.1-6.el6.x86_64                                                     6/25   Installing : cpp-4.4.7-4.el6.x86_64                                                      7/25   Installing : ppl-0.10.2-11.el6.x86_64                                                    8/25   Installing : cloog-ppl-0.15.7-1.2.el6.x86_64                                             9/25   Installing : compat-libcap1-1.10-1.x86_64                                               10/25   Installing : compat-libstdc++-33-3.2.3-69.el6.x86_64                                    11/25   Installing : ksh-20120801-10.el6_5.4.x86_64                                             12/25   Updating   : libgomp-4.4.7-4.el6.x86_64                                                 13/25   Installing : kernel-uek-headers-2.6.32-400.34.5.el6uek.x86_64                           14/25   Installing : glibc-headers-2.12-1.132.el6_5.1.x86_64                                    15/25   Installing : glibc-devel-2.12-1.132.el6_5.1.x86_64                                      16/25   Installing : gcc-4.4.7-4.el6.x86_64                                                     17/25   Installing : gcc-c++-4.4.7-4.el6.x86_64                                                 18/25   Installing : libaio-devel-0.3.107-10.el6.x86_64                                         19/25   Installing : oracle-rdbms-server-11gR2-preinstall-1.0-9.el6.x86_64                      20/25   Cleanup    : libstdc++-4.4.6-4.el6.x86_64                                               21/25   Cleanup    : libgomp-4.4.6-4.el6.x86_64                                                 22/25   Cleanup    : glibc-common-2.12-1.80.el6.x86_64                                          23/25   Cleanup    : glibc-2.12-1.80.el6.x86_64                                                 24/25   Cleanup    : libgcc-4.4.6-4.el6.x86_64                                                  25/25   Verifying  : glibc-headers-2.12-1.132.el6_5.1.x86_64                                     1/25   Verifying  : libaio-devel-0.3.107-10.el6.x86_64                                          2/25   Verifying  : gcc-4.4.7-4.el6.x86_64                                                      3/25   Verifying  : libstdc++-4.4.7-4.el6.x86_64                                                4/25   Verifying  : compat-libcap1-1.10-1.x86_64                                                5/25   Verifying  : libstdc++-devel-4.4.7-4.el6.x86_64                                          6/25   Verifying  : cpp-4.4.7-4.el6.x86_64                                                      7/25   Verifying  : kernel-uek-headers-2.6.32-400.34.5.el6uek.x86_64                            8/25   Verifying  : compat-libstdc++-33-3.2.3-69.el6.x86_64                                     9/25   Verifying  : mpfr-2.4.1-6.el6.x86_64                                                    10/25   Verifying  : glibc-common-2.12-1.132.el6_5.1.x86_64                                     11/25   Verifying  : gcc-c++-4.4.7-4.el6.x86_64                                                 12/25   Verifying  : cloog-ppl-0.15.7-1.2.el6.x86_64                                            13/25   Verifying  : ksh-20120801-10.el6_5.4.x86_64                                             14/25   Verifying  : libgomp-4.4.7-4.el6.x86_64                                                 15/25   Verifying  : oracle-rdbms-server-11gR2-preinstall-1.0-9.el6.x86_64                      16/25   Verifying  : glibc-devel-2.12-1.132.el6_5.1.x86_64                                      17/25   Verifying  : ppl-0.10.2-11.el6.x86_64                                                   18/25   Verifying  : glibc-2.12-1.132.el6_5.1.x86_64                                            19/25   Verifying  : libgcc-4.4.7-4.el6.x86_64                                                  20/25   Verifying  : libstdc++-4.4.6-4.el6.x86_64                                               21/25   Verifying  : glibc-common-2.12-1.80.el6.x86_64                                          22/25   Verifying  : glibc-2.12-1.80.el6.x86_64                                                 23/25   Verifying  : libgomp-4.4.6-4.el6.x86_64                                                 24/25   Verifying  : libgcc-4.4.6-4.el6.x86_64                                                  25/25

Installed:   oracle-rdbms-server-11gR2-preinstall.x86_64 0:1.0-9.el6                                           

Dependency Installed:   cloog-ppl.x86_64 0:0.15.7-1.2.el6                    compat-libcap1.x86_64 0:1.10-1      gcc.x86_64 0:4.4.7-4.el6                             gcc-c++.x86_64 0:4.4.7-4.el6        kernel-uek-headers.x86_64 0:2.6.32-400.34.5.el6uek   ksh.x86_64 0:20120801-10.el6_5.4    mpfr.x86_64 0:2.4.1-6.el6                            ppl.x86_64 0:0.10.2-11.el6         compat-libstdc++-33.x86_64 0:3.2.3-69.el6            cpp.x86_64 0:4.4.7-4.el6                                      glibc-devel.x86_64 0:2.12-1.132.el6_5.1              glibc-headers.x86_64 0:2.12-1.132.el6_5.1                     libaio-devel.x86_64 0:0.3.107-10.el6                 libstdc++-devel.x86_64 0:4.4.7-4.el6                       

Dependency Updated:   glibc.x86_64 0:2.12-1.132.el6_5.1    glibc-common.x86_64 0:2.12-1.132.el6_5.1    libgcc.x86_64 0:4.4.7-4.el6    libgomp.x86_64 0:4.4.7-4.el6    libstdc++.x86_64 0:4.4.7-4.el6   Complete!

f、校验结果 [root@oel63 ~]# cd /var/log/oracle-rdbms-server-11gR2-preinstall/results/ [root@oel63 results]# ls orakernel.log [root@oel63 results]# more orakernel.log Adding group oinstall with gid 54321 Adding group dba Adding user oracle with user id 54321, initial login group oinstall, supplementary group dba and  home directory /home/oracle Changing ownership of /home/oracle to oracle:oinstall Please set password for oracle user uid=54321(oracle) gid=54321(oinstall) groups=54321(oinstall),54322(dba) Creating oracle user passed

Verifying  kernel parameters as per Oracle recommendations... Adding fs.file-max = 6815744 Adding kernel.sem = 250 32000 100 128 Adding kernel.shmmni = 4096 kernel.shmall is higher than preinstall config. kernel.shmall = 4294967296 kernel.shmmax = 4398046511104 Changing kernel.shmmax to match preinstall config Adding net.core.rmem_default = 262144 Adding net.core.rmem_max = 4194304 Adding net.core.wmem_default = 262144 Adding net.core.wmem_max = 1048576 Adding fs.aio-max-nr = 1048576 Adding net.ipv4.ip_local_port_range = 9000 65500 Setting kernel parameters as per oracle recommendations... Altered file /etc/sysctl.conf Original file backed up at /etc/sysctl.conf.orabackup Verifying & setting of kernel parameters passed

Setting user limits using /etc/security/limits.conf

Verifying oracle user OS limits as per Oracle recommendations... Adding oracle soft nofile  1024 Adding oracle hard nofile  65536    .............

Setting kernel boot parameters as per Oracle recommendations... Boot parameters will be effected on next reboot Altered file /boot/grub/grub.conf Original file backed up at /boot/grub/grub.conf.orabackup Verifying & setting of boot parameters passed

Disabling Transparent Hugepages. Refer Oracle Note:1557478.1

Disabling defrag. Refer Oracle Note:1557478.1

Taking a backup of old config files under /var/log/oracle-rdbms-server-11gR2-preinstall/backup/May-16-2014-14-53-37 #最后一句给出了相关的备份信息 

#下面是查看备份文件 [root@oel63 results]# cd /var/log/oracle-rdbms-server-11gR2-preinstall/backup [root@oel63 backup]# ls May-16-2014-14-53-37 [root@oel63 backup]# cd May-16-2014-14-53-37/ [root@oel63 May-16-2014-14-53-37]# ls grub.conf  limits.conf  orakernel.log  sysctl.conf

#校验Oracle用户,注,需要为Oracle用户修改密码,此处省略 [root@oel63 ~]# cat /etc/passwd |grep oracle oracle:x:54321:54321::/home/oracle:/bin/bash [root@oel63 ~]# cat /etc/group |grep dba      dba:x:54322:oracle [root@oel63 ~]# cat /etc/group |grep oinstall oinstall:x:54321:

4、参考链接: How I Simplified Oracle Database 12c and 11g Installations on Oracle Linux 6

How I Simplified Oracle Database Installation on Oracle Linux 5

本文参与腾讯云自媒体分享计划,欢迎正在阅读的你也加入,一起分享。

我来说两句

0 条评论
登录 后参与评论

相关文章

  • MongoDB 文档字段增删改

    //$set修改器最常用,等同于RDBMS update的set子句 //演示重用的的示例集合数据请参考:mongoDB 比较运算符

    Leshami
  • Oracle 索引质量分析

          索引质量的高低对数据库整体性能有着直接的影响。良好高质量的索引使得数据库性能得以数量级别的提升,而低效冗余的索引则使得数据库性能缓慢如牛,即便是使用...

    Leshami
  • MySQL 自动故障转移工具--mysqlfailover

    Leshami
  • CentOS6.3 x86_64位安装xfce4桌面vncserver服务

    CentOS6.3 x86_64位安装xfce4桌面vncserver服务 注意这里用的是最小化安装纯净系统212个包CentOS-6.3-x86_64-...

    三杯水Plus
  • CentOS6.9下制作一键安装的ISO系统镜像

    rootpw --iscrypted $1$ymZM2uhc$2W.ZFogcbMq3qz5C7.Azd.

    yuanfan2012
  • cronie所依赖的包

    CentOS6.3 x86_64 最小化安装版安装cronie yum -y install cronie 通过这个命令可得出安装cronie所得依赖包如下

    三杯水Plus
  • docker安装

    http://dl.fedoraproject.org/pub/epel/6/x86_64/epel-release-6-8.noarch.rpm

    dodo_lihao
  • zabbix-server端与zabbix-agent端部署与监控

    环境: [root@redis ~]# uname -a Linux redis 2.6.32-696.el6.x86_64 #1 SMP Tue Mar 21...

    863987322
  • Centos中yum方式安装java

    查看CentOS自带JDK是否已安装。 ◆输入:yum list installed |grep java。 若有自带安装的JDK,如何卸载CentOS系统自带...

    洗尽了浮华
  • CentOS7.2+OpenStack+kvm 云平台部署--用OZ工具制作openstack镜像

    首先下载iso镜像,这里下载了centos6.5镜像,放到/usr/local/src目录下 然后用OZ工具制作openstack的镜像

    菲宇

扫码关注云+社区

领取腾讯云代金券