前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >PAT 1007

PAT 1007

作者头像
week
发布2018-08-27 09:33:22
2050
发布2018-08-27 09:33:22
举报
文章被收录于专栏:用户画像用户画像

Maximum Subsequence Sum (25)

Given a sequence of K integers { N1, N2, ..., NK }. A continuous subsequence is defined to be { Ni, Ni+1, ..., Nj } where 1 <= i <= j <= K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (<= 10000). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:

代码语言:javascript
复制
10
-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:

10 1 4

代码语言:javascript
复制
#include<iostream>
#include<string>
#include<queue>
using namespace std;
#define max 10000
int main()
{	
	int i,j,n,a[max],sum=-1,start,end,tmp;
	queue<int> q;
	cin>>n;
	bool f=false;
	for(i=0;i<n;i++)
	{
		cin>>a[i];
	}
	for(i=0;i<n;i++)
	{
		tmp=0;
		for(j=i;j<n;j++)
		{
			tmp+=a[j];
			if(tmp>sum)
			{
				sum=tmp;
				start=i;
				end=j;
			}
		}
	}
	if(sum<0)
	{
		cout<<0<<" "<<a[0]<<" "<<a[n-1];
	}
	else
	{
		cout<<sum<<" "<<a[start]<<" "<<a[end];
	}
    return 0;
}
本文参与 腾讯云自媒体分享计划,分享自作者个人站点/博客。
原始发表:2016年03月06日,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体分享计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
目录
  • Maximum Subsequence Sum (25)
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档