前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >1002. A+B for Polynomials (25)

1002. A+B for Polynomials (25)

作者头像
week
发布2018-08-27 10:06:53
3340
发布2018-08-27 10:06:53
举报
文章被收录于专栏:用户画像

一、题目描述

This time, you are supposed to find A+B where A and B are two polynomials.

Input

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 ... NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10,0 <= NK < ... < N2 < N1 <=1000.

Output

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input

代码语言:javascript
复制
2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output

代码语言:javascript
复制
3 2 1.5 1 2.9 0 3.2

二、代码

代码语言:javascript
复制
#include<iostream>   
#include<string.h>   
#include<cstdio>   
#include<iomanip>   
using namespace std;  
#define max 1000   
double input[max + 1];  
   
int main()  
{  
    int k,count;  
    int i,expo;  //指数
    double coef;  //系数
	//第一行多项式
    cin>>k;  
    memset(input,0,sizeof(input));  //变量初始化
    for(i=0; i<k; i++)  
    {  
        cin>>expo>>coef;  
        input[expo] += coef;  
    }
	//第二行多项式
    cin>>k;  
    for(i=0; i<k; i++)  
    {  
        cin>>expo>>coef;  
        input[expo] += coef;  
    }  
	//统计多项式和的个数
    count = 0;  
    for(i=1000; i>=0; i--) 
	{
		if(input[i] != 0) 
		{
			count++;  
		}
		
	}
    cout<<count;
	
    for(i=1000; i>=0; i--)  
        if(input[i] != 0.0)  
        {  
            cout<<fixed<<setprecision(1); 
			//加fixed表示固定点方式显示,这里的精度指的是小数位;不加fixed,则表示小数的总位数
            cout<<" "<<i<<" "<<input[i];  
        }  
    cout<<endl;  
    return 0;  
} 

本文参与 腾讯云自媒体同步曝光计划,分享自作者个人站点/博客。
原始发表:2016年02月04日,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体同步曝光计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
目录
  • 一、题目描述
  • This time, you are supposed to find A+B where A and B are two polynomials.
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档