前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >Binary String Matching

Binary String Matching

作者头像
书童小二
发布2018-09-03 17:02:54
3000
发布2018-09-03 17:02:54
举报
文章被收录于专栏:前端儿前端儿

Binary String Matching

描述

Given two strings A and B, whose alphabet consist only ‘0’ and ‘1’. Your task is only to tell how many times does A appear as a substring of B? For example, the text string B is ‘1001110110’ while the pattern string A is ‘11’, you should output 3, because the pattern A appeared at the posit

输入The first line consist only one integer N, indicates N cases follows. In each case, there are two lines, the first line gives the string A, length (A) <= 10, and the second line gives the string B, length (B) <= 1000. And it is guaranteed that B is always longer than A.输出For each case, output a single line consist a single integer, tells how many times do B appears as a substring of A.样例输入

代码语言:javascript
复制
3
11
1001110110
101
110010010010001
1010
110100010101011 

样例输出

代码语言:javascript
复制
3
0
3 
代码语言:javascript
复制
 
#include <iostream>
#include <string>

using namespace std;

int main()
{
    int n;
    cin>>n;
    while(n--)
    {
        string strA;
        string strB;
        int count = 0;
        cin>>strA;
        cin>>strB;
        int A = strA.size();
        int B = strB.size();
        for(int i=0; i<B; i++)
        {
            if(strB.substr(i, A) == strA)
                count ++;

        }
        cout<<count<<endl;
    }


    return 0;
}        
本文参与 腾讯云自媒体分享计划,分享自作者个人站点/博客。
原始发表:2014-11-02 ,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体分享计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
目录
  • Binary String Matching
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档