前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >a letter and a number

a letter and a number

作者头像
书童小二
发布2018-09-03 18:18:26
4690
发布2018-09-03 18:18:26
举报
文章被收录于专栏:前端儿前端儿

a letter and a number

描述

we define f(A) = 1, f(a) = -1, f(B) = 2, f(b) = -2, ... f(Z) = 26, f(z) = -26; Give you a letter x and a number y , you should output the result of y+f(x).

输入On the first line, contains a number T(0<T<=10000).then T lines follow, each line is a case.each case contains a letter x and a number y(0<=y<1000).输出for each case, you should the result of y+f(x) on a line样例输入

代码语言:javascript
复制
6
R 1
P 2
G 3
r 1
p 2
g 3

样例输出

代码语言:javascript
复制
19
18
10
-17
-14
-4
代码语言:javascript
复制
 
#include <iostream>
#include <string>
using namespace std;
int main()
{
    int n;
    int a,b;
    char ch;
    cin>>n;
    while(n--)
    {
        cin>>ch;
        cin>>a;
        if(ch>=65 && ch<=90)
            ch -=64;
        else
            ch = 96-ch;

        b = a +ch;
        cout<<b <<endl;
    }
return 0;
}        
本文参与 腾讯云自媒体分享计划,分享自作者个人站点/博客。
原始发表:2014-11-02 ,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体分享计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
目录
  • a letter and a number
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档