前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >poj-1163-The Triangle

poj-1163-The Triangle

作者头像
瑾诺学长
发布2018-09-21 16:08:50
4340
发布2018-09-21 16:08:50
举报
文章被收录于专栏:专注研发

Description

代码语言:javascript
复制
7
3   8
8   1   0
2   7   4   4
4   5   2   6   5

(Figure 1)

Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right.

Input

Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99.

Output

Your program is to write to standard output. The highest sum is written as an integer.

Sample Input

代码语言:javascript
复制
5
7
3 8
8 1 0 
2 7 4 4
4 5 2 6 5

Sample Output

代码语言:javascript
复制
30
题目大意:
求从最上面到最下面的最大和;参照Figure 1图
代码语言:javascript
复制
#include<iostream>
using namespace std;
int main()
{

   int n,aa[100][100];
   cin>>n;
   for(int i=0;i<n;i++)
    for(int j=0;j<=i;j++)
    cin>>aa[i][j];

    for(int i=n-2;i>=0;i--)//为什么要n-2呢??
                //思路是从倒数第一行开始把值加到上面一行,这样得到的aa[0][0]一定是最大值
   {
       for(int j=0;j<=i;j++)
       {
           aa[i][j]+=max(aa[i+1][j],aa[i+1][j+1]);
       }
   }
cout<<aa[0][0]<<endl;


return 0;
}
例如:
5
7
3 8
8 1 0 
2 7 4 4
4 5 2 6 5
执行之后结果:
30
23 8
20 1 0 
7 12 4 4
4 5 2 6 5
代码语言:javascript
复制
本文参与 腾讯云自媒体同步曝光计划,分享自作者个人站点/博客。
原始发表:2016-03-18 ,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体同步曝光计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档