前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >poj-1046-color me less

poj-1046-color me less

作者头像
瑾诺学长
发布2018-09-21 16:09:30
3730
发布2018-09-21 16:09:30
举报
文章被收录于专栏:专注研发专注研发专注研发

Description

A color reduction is a mapping from a set of discrete colors to a smaller one. The solution to this problem requires that you perform just such a mapping in a standard twenty-four bit RGB color space. The input consists of a target set of sixteen RGB color values, and a collection of arbitrary RGB colors to be mapped to their closest color in the target set. For our purposes, an RGB color is defined as an ordered triple (R,G,B) where each value of the triple is an integer from 0 to 255. The distance between two colors is defined as the Euclidean distance between two three-dimensional points. That is, given two colors (R1,G1,B1) and (R2,G2,B2), their distance D is given by the equation

Input

The input is a list of RGB colors, one color per line, specified as three integers from 0 to 255 delimited by a single space. The first sixteen colors form the target set of colors to which the remaining colors will be mapped. The input is terminated by a line containing three -1 values.

Output

For each color to be mapped, output the color and its nearest color from the target set. If there are more than one color with the same smallest distance, please output the color given first in the color set.

Sample Input

0 0 0
255 255 255
0 0 1
1 1 1
128 0 0
0 128 0
128 128 0
0 0 128
126 168 9
35 86 34
133 41 193
128 0 128
0 128 128
128 128 128
255 0 0
0 1 0
0 0 0
255 255 255
253 254 255
77 79 134
81 218 0
-1 -1 -1
题目大意:
前十六个数据代表已存入map的位置,根据公式求得数据到最近的已存在位置;

Sample Output

#include<cmath>
#include<iostream>
#include<algorithm>
using namespace std;
struct mapa
{

int a;
int b;
int c;

};

int main()
{  mapa aa[16];
    for(int i=0;i<16;i++)
    {
        cin>>aa[i].a>>aa[i].b>>aa[i].c;

    }
     int x,y,z;
    while(cin>>x>>y>>z)
    {
        if(x==-1&&y==-1&&z==-1)break;
        int zh=255*255*3;
        int d,j=0;
        for(int i=0;i<16;i++)
        {
            d=sqrt((aa[i].a-x)*(aa[i].a-x)+(aa[i].b-y)*(aa[i].b-y)+(aa[i].c-z)*(aa[i].c-z));

            if(d<zh){zh=d;j=i;}


        }
        cout<<'('<<x<<','<<y<<','<<z<<')'<<" maps to "<<'('<<aa[j].a<<','<<aa[j].b<<','<<aa[j].c<<')'<<endl;

    }
system("pause");

    return 0;
}
(0,0,0) maps to (0,0,0)
(255,255,255) maps to (255,255,255)
(253,254,255) maps to (255,255,255)
(77,79,134) maps to (128,128,128)
(81,218,0) maps to (126,168,9)
本文参与 腾讯云自媒体分享计划,分享自作者个人站点/博客。
原始发表:2016-03-20 ,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体分享计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档