前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >poj-1056-IMMEDIATE DECODABILITY(字典)

poj-1056-IMMEDIATE DECODABILITY(字典)

作者头像
瑾诺学长
发布2018-09-21 16:10:17
3460
发布2018-09-21 16:10:17
举报
文章被收录于专栏:专注研发

Description

An encoding of a set of symbols is said to be immediately decodable if no code for one symbol is the prefix of a code for another symbol. We will assume for this problem that all codes are in binary, that no two codes within a set of codes are the same, that each code has at least one bit and no more than ten bits, and that each set has at least two codes and no more than eight. Examples: Assume an alphabet that has symbols {A, B, C, D} The following code is immediately decodable: A:01 B:10 C:0010 D:0000 but this one is not: A:01 B:10 C:010 D:0000 (Note that A is a prefix of C)

Input

Write a program that accepts as input a series of groups of records from standard input. Each record in a group contains a collection of zeroes and ones representing a binary code for a different symbol. Each group is followed by a single separator record containing a single 9; the separator records are not part of the group. Each group is independent of other groups; the codes in one group are not related to codes in any other group (that is, each group is to be processed independently).

Output

For each group, your program should determine whether the codes in that group are immediately decodable, and should print a single output line giving the group number and stating whether the group is, or is not, immediately decodable.

Sample Input

代码语言:javascript
复制
01
10
0010
0000
9
01
10
010
0000
9

Sample Output

代码语言:javascript
复制
Set 1 is immediately decodable
Set 2 is not immediately decodable
 题目大意:
就是输多组0 1数据,任意一组数据不能成为另一种的前缀;

一组符号的编码是立即可解码的如果没有前缀的代码一个符号代码的另一个象征。我们将假定这个问题,所有的二进制代码,没有两个编码在一组编码是相同的,每个代码至少有一个,不超过十位,每组至少有两个编码和不超过8个。

例子:假设一个字母,符号{ A,B,C,D }

下面的代码是立即可解码

代码语言:javascript
复制
#include<iostream>
#include<string>
#include<cstring>
using namespace std;
int main()
{

 string  str[10];
   int i=0; int y=1,w=0;
    while(cin>>str[i])
    {

        if(str[i]=="9")
        {
            i=0;
            w++;
            if(y==1)cout<<"Set "<<w<<" is immediately decodable"<<endl;
            else cout<<"Set "<<w<<" is not immediately decodable"<<endl;
            y=1;

        }

         int len=str[i].length();      //新输入字符长度
        for(int j=0;j<i;j++)           //没输一组数据都与原来的进行比较
        {
            int t=0;
           int len1=str[j].length();     //已存入数据的字符长度
            for(int k=0;k<len&&k<len1;k++)    //保证以短的字符串长度为比较界限
            {
                if(str[i][k]==str[j][k])
                {

                        t++;
                }


            }
            if(t==min(len,len1)){y=0;break;}  //若等式成立则说明此字符串必为某字符串前缀


        }
        i++;
    }



    return 0;

}
代码语言:javascript
复制
本文参与 腾讯云自媒体同步曝光计划,分享自作者个人站点/博客。
原始发表:2016-03-22 ,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体同步曝光计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档