前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >poj-1012-约瑟夫问题

poj-1012-约瑟夫问题

作者头像
瑾诺学长
发布2018-09-21 16:12:02
5870
发布2018-09-21 16:12:02
举报
文章被收录于专栏:专注研发专注研发

Description

The Joseph's problem is notoriously known. For those who are not familiar with the original problem: from among n people, numbered 1, 2, . . ., n, standing in circle every mth is going to be executed and only the life of the last remaining person will be saved. Joseph was smart enough to choose the position of the last remaining person, thus saving his life to give us the message about the incident. For example when n = 6 and m = 5 then the people will be executed in the order 5, 4, 6, 2, 3 and 1 will be saved. Suppose that there are k good guys and k bad guys. In the circle the first k are good guys and the last k bad guys. You have to determine such minimal m that all the bad guys will be executed before the first good guy.

Input

The input file consists of separate lines containing k. The last line in the input file contains 0. You can suppose that 0 < k < 14.

Output

The output file will consist of separate lines containing m corresponding to k in the input file.

Sample Input

代码语言:javascript
复制
3
4
0

Sample Output

代码语言:javascript
复制
5
30
题目大意:
有k个好人和k个坏人,从第一个人开始循环报数(即报到m后从1开始报),报到m的人被处死,要求全部的坏人都处死,好人留下,求出m。
代码语言:javascript
复制
这个代码就是有点慢,所以我打了个表


#include<iostream>
using namespace std;
int main()
{
    int k;
    while(cin>>k)
    {
        if(!k)
            break;

    int m=1;
    int ans[30]={0};
    for(int i=1;i<=k;i++)
    {
        ans[i]=(ans[i-1]+m-1)%(2*k-i+1);
        if(ans[i]<k)
        {
            i=0;m++;
        }
    }
    cout<<m<<endl;

    }

    return 0;
}

    }
    sort(yes,yes+n,cmp);

    sort(no,no+n,cmp);
    cout<<yes[n-1]<<" "<<no[n-1]<<endl;


    return 0;


}
代码语言:javascript
复制
#include<stdio.h>
int main()
{
	int k;
	int Joseph[14]={0,2,7,5,30,169,441,1872,7632,1740,93313,459901,1358657,2504881};
	while(scanf("%d",&k),k)
		printf("%d\n",Joseph[k]);
	return 0;
}
本文参与 腾讯云自媒体分享计划,分享自作者个人站点/博客。
原始发表:2016-03-15 ,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体分享计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档