前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >poj-2551-ones

poj-2551-ones

作者头像
瑾诺学长
发布2018-09-21 16:12:15
2450
发布2018-09-21 16:12:15
举报
文章被收录于专栏:专注研发

Description

Given any integer 0 <= n <= 10000 not divisible by 2 or 5, some multiple of n is a number which in decimal notation is a sequence of 1's. How many digits are in the smallest such a multiple of n?

Input

Each line contains a number n.

Output

Output the number of digits.

Sample Input

代码语言:javascript
复制
3 
7 
9901

Sample Output

代码语言:javascript
复制
3
6
12

题目大意:
输入n,求出不能整除3和5,却能整除d并且这个数各位都是1;
111111111111%9901==0;
代码语言:javascript
复制
#include <iostream>
#include <cstdio>

using namespace std;


int main()
{
    int n;

    while(~scanf("%d",&n))//EOF
    {
        int cnt=1;
        int num=1;

        while(num%n)
        {
            num=(num*10+1)%n;//直接找由1构成的数,判断是不是n的倍数
            cnt++;
        }
        printf("%d\n",cnt);
    }

    return 0;
}
本文参与 腾讯云自媒体同步曝光计划,分享自作者个人站点/博客。
原始发表:2016-03-15 ,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体同步曝光计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档