首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >poj-1503-java大数相加

poj-1503-java大数相加

作者头像
瑾诺学长
发布2018-09-21 16:25:29
6360
发布2018-09-21 16:25:29
举报
文章被收录于专栏:专注研发专注研发专注研发

Description

One of the first users of BIT's new supercomputer was Chip Diller. He extended his exploration of powers of 3 to go from 0 to 333 and he explored taking various sums of those numbers. ``This supercomputer is great,'' remarked Chip. ``I only wish Timothy were here to see these results.'' (Chip moved to a new apartment, once one became available on the third floor of the Lemon Sky apartments on Third Street.)

Input

The input will consist of at most 100 lines of text, each of which contains a single VeryLongInteger. Each VeryLongInteger will be 100 or fewer characters in length, and will only contain digits (no VeryLongInteger will be negative). The final input line will contain a single zero on a line by itself.

Output

Your program should output the sum of the VeryLongIntegers given in the input.

Sample Input

123456789012345678901234567890
123456789012345678901234567890
123456789012345678901234567890
0

Sample Output

370370367037037036703703703670
第一道java题,好开森;
import java.util.*;

import java.math.*;

import java.io.*;
public class Main{        //外面的Main必须大写!

public static void main(String[] args){   //String  S大写

Scanner cin= new Scanner(System.in);  
BigDecimal a=BigDecimal.valueOf(0);    //组合的函数名一般后个一定得大写: BigInter  BigDecimal  valueOf(这前不大写)  hasNext nextLine;
BigDecimal b=BigDecimal.valueOf(0);   //赋初值
String  str;
while(cin.hasNext())     //相当于!=EOF
{  
   str=cin.nextLine();    //下一行输入nextLine
   if(str.equals("0"))    //equals
   {
       break;
   }
   else 
    {
        a=new BigDecimal(str); //强制转化,把str转化成大数
        b=b.add(a);     //b+a;
        
    }
    
}
System.out.println(b.toPlainString());   //println,是LN
                        //toPlainString 以字符形式输出
}




}
本文参与 腾讯云自媒体分享计划,分享自作者个人站点/博客。
原始发表:2016-03-24 ,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体分享计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档