首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >poj 2503 查字典

poj 2503 查字典

作者头像
瑾诺学长
发布2018-09-21 16:39:30
6330
发布2018-09-21 16:39:30
举报
文章被收录于专栏:专注研发专注研发

Description

You have just moved from Waterloo to a big city. The people here speak an incomprehensible dialect of a foreign language. Fortunately, you have a dictionary to help you understand them.

Input

Input consists of up to 100,000 dictionary entries, followed by a blank line, followed by a message of up to 100,000 words. Each dictionary entry is a line containing an English word, followed by a space and a foreign language word. No foreign word appears more than once in the dictionary. The message is a sequence of words in the foreign language, one word on each line. Each word in the input is a sequence of at most 10 lowercase letters.

Output

Output is the message translated to English, one word per line. Foreign words not in the dictionary should be translated as "eh".

Sample Input

dog ogday
cat atcay
pig igpay
froot ootfray
loops oopslay

atcay
ittenkay
oopslay

Sample Output

cat
eh
loops

其实用cin输入输出也可以
map<T,T>dd;
以及gets(a)与sscanf(a,"%s",str)配合用法;
a为char a[45];
#include<cstdio>
#include<string>
#include<iostream>
#include<map>
using namespace std;

int main()
{    map<string,string>dic;
    char a[11],b[11];
    int i=0;
 char str[21];
    while(gets(str))
    {
      if(str[0]=='\0'){break;}
      sscanf(str,"%s %s",a,b);
     dic[b]=a;
    }
    char c[11];
 string qq;
    while(scanf("%s",c)!=EOF)
        {
             string s=c;
           qq=dic[s];
           if(qq.length()==0)cout<<"eh"<<endl;
           else cout<<qq<<endl;

        }

    return 0;
}
本文参与 腾讯云自媒体分享计划,分享自作者个人站点/博客。
原始发表:2016-05-29 ,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体分享计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档